Ask Your Question
1

VMware & VNC console [closed]

asked 2013-11-21 08:02:25 -0600

Romain gravatar image

updated 2014-01-22 15:12:22 -0600

Evgeny gravatar image

Hello, I have configured my nova.conf files in both controller and compute nodes as the documentation explained: http://docs.openstack.org/trunk/install-guide/install/apt/content/nova-compute.html

I have created a vmware virtual machine using the ESXdriver but I'm not able to have a vnc console working. I have found this bug on launchpad but I would rather have the confirmation that the vnc console does not work with vmware. https://bugs.launchpad.net/openstack-manuals/+bug/1212299

Has any of you been able to make the vnc console worked with vmware VMs?

Thanks beforehand.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Romain
close date 2013-12-20 06:38:11.364452

6 answers

Sort by ยป oldest newest most voted
0

answered 2013-11-24 19:10:12 -0600

fifieldt gravatar image

I have seen demos of the VNC console working fine with VMWare. However, I believe you need to do some configuration to make it work, as noted in the bug report.

edit flag offensive delete link more
2

answered 2013-12-03 12:06:13 -0600

antonnoble gravatar image

I have VNC working fine with my OpenStack+vSphere deployment. I am connecting to vCenter and not directly to the ESX Hosts. However according to VMWare you do have to open the ports on the hypervisor by either the esxcli, powercli, or the vSphere Client.

On the vSphere Client you select the host then configuration > firewall properties > gdbserver > select the checkbox > click ok. (this is really only for testing purposes) For production you would want to limit the ports to 5900-6000.

Nova.conf (My controller and compute node live on the same server, and this is configuration is for testing only)

[default]
vncserver_proxyclient_address = IP of your Controller
vncserver_listen = 0.0.0.0
vncserver_enabled = True
novncproxy_host = 0.0.0.0
novncproxy_port = 6080
novncproxy_base_url = http://mycontroller:6080/vnc_auto.html

Make sure you have the nova-novncproxy and nova-consoleauth packages installed. If you have your firewall enabled on your controller I would disable it.

I am having problems making SPICE protocol work with vSphere at the moment.

edit flag offensive delete link more

Comments

After you have configured the nova.conf properly. Restart services: service nova-compute restart service nova-novncproxy restart service nova-consoleauth restart service apache2 restart Reload the Horizon dashboard in the browser.

antonnoble gravatar imageantonnoble ( 2013-12-03 12:08:21 -0600 )edit
0

answered 2013-12-03 05:04:57 -0600

i stumbled upon this blog : http://trickycloud.wordpress.com/2013/11/03/enable-console-access-to-vsphere-instances-in-openstack/ Hope this helps.

edit flag offensive delete link more
0

answered 2013-11-24 23:51:28 -0600

ken-hui gravatar image

Have you enabled port ranges 5900 - 6000 for VNC Connections on your ESXi hosts? If you haven't, the easiest way to do so is to enable the gdbserver in the security profile for each host.

edit flag offensive delete link more
0

answered 2013-11-24 23:27:08 -0600

pocketlion gravatar image

you can try to add vnc console passwd for the vm on the exsi host and then reconnect the console using the passwd you set

edit flag offensive delete link more
0

answered 2013-12-20 06:37:21 -0600

Romain gravatar image

updated 2013-12-20 06:37:40 -0600

Hello, I solved my problem by changing the browser. On Chrome, I don't manage to display the console, but it works on Firefox. It may be due to ports blocking on chrome. Anyway, thanks for you help.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-21 08:02:25 -0600

Seen: 2,035 times

Last updated: Dec 20 '13