Ask Your Question
0

instance can't get IP from dhcp agent when using linux bridge plugin

asked 2013-11-18 01:52:01 -0500

chen-li gravatar image

updated 2013-11-20 02:45:26 -0500

darragh-oreilly gravatar image

Hi list,

I'm working under CentOS 6.4 + Havana.

I'm using neutron with core_plugin = neutron.plugins.linuxbridge.lb_neutron_plugin.LinuxBridgePluginV2

And, I have created a network with VLAN ID = 2002.

After an instance created, everything works fine, but the instance can't get IP from DHCP agent.

On the machine which is running dhcp agent:

    brctl show
    bridge name bridge id STP enabled interfaces
    brq5e04f269-94 8000.1239a4bc0e67 no eth4.2002
                                                            tap4647c381-05

    tcpdump -i eth4.2002
    15:47:58.339767 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from fa:16:3e:80:53:02 (oui Unknown), length 300

    tcpdump -i tap4647c381-05
    .... nothing ........

$ ip link 
6:  eth4: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq state UP qlen 1000 
    link/ether 90:e2:ba:42:41:c4 brd ff:ff:ff:ff:ff:ff 
93: tap4647c381-05: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 12:39:a4:bc:0e:67 brd ff:ff:ff:ff:ff:ff
94: eth4.2002@eth4: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UP 
    link/ether 90:e2:ba:42:41:c4 brd ff:ff:ff:ff:ff:ff 
95: brq5e04f269-94: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 12:39:a4:bc:0e:67 brd ff:ff:ff:ff:ff:ff

Anyone know why this happen ????

Thanks. -chen

edit retag flag offensive close merge delete

Comments

Are you using IP namespaces? Are there any errors in the dhcp agent log? Can you append the output of 'ip link' to the question.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-11-18 10:08:51 -0500 )edit

Yes, I'm using default value for most configure, so I'm using IP namespaces I think. Only error in DHCP agent is when I start it: 2013-11-18 15:41:04.064 81923 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver, is this related ???

chen-li gravatar imagechen-li ( 2013-11-19 19:51:36 -0500 )edit

On the compute node and network node, does the linuxbridge agent log have any errors? For the network node, can you append the output of 'ip netns' to the question.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-11-20 02:48:01 -0500 )edit

@chen-li The question is a lot more readable if you add details editing your original question instead of comments

smaffulli gravatar imagesmaffulli ( 2013-11-20 14:13:45 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-25 00:39:04 -0500

laocius gravatar image

I am having the same issue? did you get it resolved?

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-18 01:52:01 -0500

Seen: 561 times

Last updated: Dec 25 '13