Ask Your Question
3

Text editors (vim, nano, emacs) freezes my ssh session in Ubuntu instances (13.10, 13.04, and 12.04.2 server) [closed]

asked 2013-11-15 13:16:48 -0600

Magnus gravatar image

I have spent several days now on debugging the problem, and I can not find anything in the logs (have been looking in Grizzly's logs and in logs within the instances).

The strange thing is that everything works fine, spinning up an instants, adding a floating IP, and connecting via ssh. I can echo text into a new text file and later view the content using cat or less. However, if I try vim, nano, or emacs, my session freezes on me.

I have no problems using vim, nano, or emacs over ssh from my client on other systems (on AWS and on a local Ubuntu server) not running in my OpenStack installation.

Right now I'm stuck, and I don't find anything in the logs. I'm just hoping that a friendly guru can give me some new ideas on how to approach this strange behavior.

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by laboshinl
close date 2013-11-22 15:33:43.302289

2 answers

Sort by ยป oldest newest most voted
5

answered 2013-11-15 13:28:59 -0600

updated 2013-11-15 13:32:21 -0600

Sounds like an MTU problem. First of all try to decrease mtu on eth0 inside vm

ifconfig eth0 mtu 1454

If it does the trick add this option to dhcp config:

  1. create file /etc/neutron/dnsmasq-neutron.conf

    dhcp-option-force=26,1454

  2. edit /etc/neutron/dhcp_agent.ini:

    [DEFAULT] dnsmasq_config_file = /etc/neutron/dnsmasq-neutron.conf

Related link: http://unix.stackexchange.com/questions/14629/running-vim-on-a-remote-linux-machine-freezes-os-x-ssh-connection

edit flag offensive delete link more
2

answered 2013-11-15 15:47:15 -0600

Magnus gravatar image

Thanks!!

That solved my problem.

I created "/etc/quantum/dnsmasq-quantum.conf" added "dhcp-option-force=26,1454" to it, and added a line under [DEFAULT] "dnsmasq_config_file = /etc/quantum/dnsmasq-quantum.conf" in "/etc/quantum/dhcp_agent.ini".

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-15 13:16:48 -0600

Seen: 4,083 times

Last updated: Nov 15 '13