Ask Your Question
0

Setting up nova-common (2012.1.3 stable-20130423-e52e6912-0ubuntu1.2) ...

asked 2013-11-15 11:14:16 -0500

rony gravatar image

updated 2013-11-15 11:32:21 -0500

Stack.sh always fails while "Setting up nova-common (2012.1.3+stable-20130423-e52e6912-0ubuntu1.2) ..." What's the resolution to this?

Below is a snippet from the logs

Setting up nova-common (2012.1.3+stable-20130423-e52e6912-0ubuntu1.2) ...
usermod: no changes
chown: cannot access `/etc/nova/': No such file or directory
dpkg: error processing nova-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of nova-compute:
 nova-compute depends on nova-common (= 2012.1.3+stable-20130423-e52e6912-0ubuntu1.2); however:
  Package nova-common is not configured yet.
dpkg: error processing nova-compute (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nova-compute-kvm:
 nova-compute-kvm depends on nova-compute (= 2012.1.3+stable-20130423-e52e6912-0ubuntu1.2); however:
  Package nova-compute is not configured yet.
dpkg: error processing nova-compute-kvm (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                   Errors were encountered while processing:
 nova-common
 nova-compute
 nova-compute-kvm
E: Sub-process /usr/bin/dpkg returned an error code (1)
+++ failed
+++ local r=100
++++ jobs -p
+++ kill
+++ set +o xtrace
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-11-19 22:06:06 -0500

fifieldt gravatar image

Something's gone badly wrong with your installation.

Try again from a clean machine, and if you get the problem again report a bug at devstack: https://bugs.launchpad.net/devstack/+filebug

edit flag offensive delete link more

Comments

Makes sense. Thanks.

rony gravatar imagerony ( 2013-11-21 23:21:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-11-15 11:14:16 -0500

Seen: 641 times

Last updated: Nov 19 '13