Ask Your Question
1

Havana- Unable to ping instances from host machine

asked 2013-11-15 08:43:30 -0500

sngirame gravatar image

I have a AIO Havana installation with neutron on single nic machine. I have created a test cirros instances .I can connect to the VM through browser & can see ip assigned to it.

By default , the instance is getting an ip 172.24.4.227 , I am not able to ping it from the host machine. From instance(172.24.4.227), I can ping 172.24.4.228 (network:dhcp) From instance(172.24.4.227), I can not ping 172.24.4.226 (network:router_gateway) From host (AIO setup), I can only ping 172.24.4.225 (br-ex ip) nothing else.

I have created VM2 (172.24.4.229) from where I can ping/SSH VM1(172.24.4.227), but both these VMs cant be accessed (SSH/ping) from host.

moderators ..please do not close this thread since the problem seems to be unique though it might sound similar. Thanks

edit retag flag offensive close merge delete

Comments

what is AIO?

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-11-15 12:07:49 -0500 )edit

AIO = "All in one", everything installed on a single node, like DevStack.

lorin gravatar imagelorin ( 2013-11-15 12:20:41 -0500 )edit
1

Thanks Lorin. @sngirame - it looks like you are booting your instances to an external network, as the interface br-ex (which is external) has 172.24.4.225 which is in 172.24.4.224/28.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-11-15 12:48:27 -0500 )edit

In ovs-vsctl show I can see br-ex as internal bridge... Bridge br-ex Port br-ex Interface br-ex type: internal Also the bridge br-int does not have ipv4 address.

sngirame gravatar imagesngirame ( 2013-11-17 21:39:18 -0500 )edit

So I'm talking about internal/external Neutron networks. You need to boot to an internal (aka private, aka tenant) network. That network needs to be connected to a router which has its external gateway set to the external network. Then you will need to associate a floating IP.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-11-18 00:09:07 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-11-15 10:45:59 -0500

updated 2013-11-18 03:28:07 -0500

Are you using namespaces? If so it's pretty normal. You should specify router ID like this

root@cloudlet:~# ping 10.181.106.1
PING 10.181.106.1 (10.181.106.1) 56(84) bytes of data.
^C
--- 10.181.106.1 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

root@cloudlet:~# ip netns exec qrouter-16453c5e-f615-4eba-b142-cffccad4f303 ping 10.181.106.1
PING 10.181.106.1 (10.181.106.1) 56(84) bytes of data.
64 bytes from 10.181.106.1: icmp_req=1 ttl=64 time=0.090 ms
64 bytes from 10.181.106.1: icmp_req=2 ttl=64 time=0.057 ms

As darragh-oreilly mentioned you should have the following neutron network structure: image description

edit flag offensive delete link more

Comments

1

I can ping router using ip netns however can not ping instance from host using the same method

sngirame gravatar imagesngirame ( 2013-11-17 21:47:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-15 08:43:30 -0500

Seen: 2,493 times

Last updated: Nov 18 '13