Ask Your Question

Not able to launch horizon - connection timeout [closed]

asked 2013-11-13 03:58:53 -0500

parash_hallur gravatar image


I'm having issue launching the horizon UI after the successful install of the stack.

I have installed the stack on RHEL 6.4 VM by following the instructions at Following are my installation steps.

  1. Login as ‘root’ user
  2. Created/added the user stack ( adduser stack )
  3. Set the password for the stack user ( passwd stack )
  4. Added the user for sudo privileges (echo "stack ALL=(ALL) NOPASSWD: ALL" >> /etc/sudoers)
  5. Logout and login as ‘stack’ user
  6. Cloned the devstack (git clone )
  7. Created the localrc with required entries
  8. Ran the ./ script ( installation went through without any errors )
  9. Stopped the iptables

The installation went through fine, I did not see any failures/errors in the summary the ./ had displayed. After all these steps, I tried to access the UI and I'm getting the connection timeout error.

I checked the httpd.conf file and increased the timeout value to 300, no luck.

I don't see any errors in the httpd log files, though some entries found in the error_log file under /var/log/httpd, they are as below.

[Wed Nov 13 00:26:21 2013] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0 [Wed Nov 13 00:26:21 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) [Wed Nov 13 00:26:21 2013] [notice] Digest: generating secret for digest authentication ... [Wed Nov 13 00:26:21 2013] [notice] Digest: done [Wed Nov 13 00:26:21 2013] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 configured -- resuming normal operations

I have even tried same steps on the physical RHEL 6.4 host to, facing same issues in both places.

Please let me know if I'm missing something or doing something wrong. Any help is highly appreciated.

Thanks, Parash

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2013-12-02 23:51:31.022115

2 answers

Sort by » oldest newest most voted

answered 2013-11-14 00:44:39 -0500

parash_hallur gravatar image

Dheeru: Thanks for your reply. The issue is resolved now. I had stopped the iptables as stack user, the command did not through any error, it was silent, hence I had thought iptables might have stopped, I did not bother to check the status.

Later, I checked the status of iptables as root as user, it was still running, stopping them as root helped me. I'm able to launch the UI.

Thanks again, Parash

edit flag offensive delete link more


Traffic was blocked and you had connection timeout ?

dheeru gravatar imagedheeru ( 2013-11-14 01:05:45 -0500 )edit

I think so

parash_hallur gravatar imageparash_hallur ( 2013-11-14 02:15:25 -0500 )edit

that is good. You disabled all the firewall rules as root. Is that correct ? If my ans has given any clue for the problem can you vote my ans ? Just click on the up-arrow which next to my ans.

dheeru gravatar imagedheeru ( 2013-11-14 02:36:22 -0500 )edit

Hello I am having the same problem I am running on ubuntu. I used sudo ufw disable. Even after that i am getting this message and nothing else after ./ sudo tail -f /var/log/apache2/horizon_error.log stack@vamceep:~/devstack$ sudo tail -f /var/log/apache2/horizon_error.log

vamsi gravatar imagevamsi ( 2016-02-26 07:50:38 -0500 )edit

answered 2013-11-13 11:00:49 -0500

dheeru gravatar image

Hope are you are using port 80 for this. Run ps -aef | grep httpd and ensure that it running perfectly. Also can you do 'telnet <localip> 80'.</localip>

Are you launching horizon from same box or different box ? You can put the web-server in debug mode and see what happens.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-11-13 03:58:53 -0500

Seen: 744 times

Last updated: Nov 14 '13