Multinode setup and instance on one compute does'nt get IP

asked 2015-07-08 08:11:06 -0500

dipsubha gravatar image

updated 2015-07-09 00:30:58 -0500

Hi,

We have setup SUSE Openstack cloud 5 on three nodes(SLES-11 SP3) configured as below

  1. Exclusive admin node (SUSE Crowbar)
  2. Compute node - 1 (nova, cinder and neutron services are deployed on this node)
  3. Compute node - 2 (nova, cinder are deployed on the node)

We have deployed the services and able to launch instances. But the instances hosted on compute node -2 do not get any IP, but we can see from the dashboard the IP being assigned is 192.168.123.5. We haved used openvswitch and gre for neutron deployment through openstack barclamps.

we are using TP-LINK(TL-WR740N) router for network connection which is a basic router.

so in brief:

d3c-1e-04-46-f0-3e(Compute node -1) : This node has controller ,cinder ,nova and neutron-server and neutron l3. We have launched instance and the instance got an ip 192.168.123.6 successfully.

db8-ca-3a-78-d8-62(Compute node -2) : This node has nova and cinder. We are able to launch instance but no IP so far, but dashboard show the as IP 192.168.123.5

neutron agent list:

d3c-1e-04-46-f0-3e is controller-compute-cinder-neutron db8-ca-3a-78-d8-62 is compute-cinder

root@d3c-1e-04-46-f0-3e:/var/log/neutron # neutron agent-list

+--------------------------------------+--------------------+--------------------+-------+----------------+---------------------------+
| id | agent_type | host | alive | admin_state_up | binary |
+--------------------------------------+--------------------+--------------------+-------+----------------+---------------------------+
| 48f53d56-0df9-4245-bcd2-3a484a74ef21 | Open vSwitch agent | db8-ca-3a-78-d8-62 | :-) | True | neutron-openvswitch-agent |
| 3a555579-b31e-4893-bb44-f5871a1e966f | Open vSwitch agent | d3c-1e-04-46-f0-3e | :-) | True | neutron-openvswitch-agent |
| 4dac44cf-5ff6-40c0-a643-ded4ad798282 | L3 agent | d3c-1e-04-46-f0-3e | :-) | True | neutron-l3-agent |
| 7977a63d-d4b4-4436-823d-3fcd0f191c44 | Metering agent | d3c-1e-04-46-f0-3e | :-) | True | neutron-metering-agent |
| 73a34949-9188-474d-86c0-606d30ec7e78 | Loadbalancer agent | d3c-1e-04-46-f0-3e | :-) | True | neutron-lbaas-agent |
| a5617553-525e-4e62-9281-c8290dc74d06 | DHCP agent | d3c-1e-04-46-f0-3e | :-) | True | neutron-dhcp-agent |
| 8fa37573-6b15-4a56-bb3f-e8988a907d91 | Metadata agent | d3c-1e-04-46-f0-3e | :-) | True | neutron-metadata-agent |
+--------------------------------------+--------------------+--------------------+-------+----------------+---------------------------+

Here is the output of ifconfig and ovs-vsctl show

Command on the controller-compute-cinder-neutron node (d3c-1e-04-46-f0-3e):

root@d3c-1e-04-46-f0-3e:/var/log/neutron # ifconfig

br-int Link encap:Ethernet HWaddr 5A:6C:9C:50:46:41
inet6 addr: fe80::dc82:f8ff:fe05:6bba/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:69 errors:0 dropped:0 overruns:0 frame:0 TX packets:2 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:5570 (5.4 Kb) TX bytes:180 (180.0 b)

br-public Link encap:Ethernet HWaddr 3C:1E:04:46:F0:3E
inet addr:192.168.126.2 Bcast:0.0.0.0 Mask:255.255.255.0 inet6 addr: fe80::d802:c2ff:fe1f:b14f/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:75 errors:0 dropped:0 overruns:0 frame:0 TX packets:83 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:6218 (6.0 Kb) TX bytes:6214 (6.0 Kb)

br-tunnel Link encap:Ethernet HWaddr 36:1B:D7:95:B1:44
inet6 addr: fe80::5c6a:c3ff:feca:a38f/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:2 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 b) TX bytes:180 (180.0 b)

eth0 Link encap:Ethernet HWaddr 3C:1E:04:46:F0:3E
inet addr:192.168.124.82 Bcast:192.168.124.255 Mask:255.255.255 ...
(more)

edit retag flag offensive close merge delete

Comments

hi, can any one help me out?

dipsubha gravatar imagedipsubha ( 2015-07-09 09:25:31 -0500 )edit

please let me know the way out

dipsubha gravatar imagedipsubha ( 2015-07-12 23:35:15 -0500 )edit

we have now deployed SUSE cloud 5 with 4 different nodes..

  1. admin server
  2. controller node
  3. compute and cinder.
    4.compute and cinder.

now also the instances hosted by this two compute nodes is not having ip. but in dashboard ip is being shown. please help me out. this is urgent.

dipsubha gravatar imagedipsubha ( 2015-07-13 03:38:24 -0500 )edit