Ask Your Question
1

Cinder volume doesn't attach

asked 2013-11-12 11:06:24 -0500

Esteban gravatar image

Openstack cinder volumes are created and the ISCSI daemon creates a target for them, however when one tries to attach such volume to an instance, in the user interface of Openstack the volumes goes to the status attaching and then it comes back to the status available, instead of presenting the attached status as a normal operation would make it.

Logging information

In the compute nodes where the instance where the volumes was supposed to be attached, one will find this entry (the following example includes timestamps and nodes that are might not be accurate in your environment)

2013-10-09 09:53:48.905 27767 TRACE nova.openstack.common.rpc.amqp ProcessExecutionError: Unexpected error while running command. 2013-10-09 09:53:48.905 27767 TRACE nova.openstack.common.rpc.amqp Command: sudo nova-rootwrap /etc/nova/rootwrap.conf iscsiadm -m node -T iqn.2010-10.org.openstack:volume-7817aa43-755e-43b7-8959-092515c0910c -p 172.20.2.27:3260 --rescan 2013-10-09 09:53:48.905 27767 TRACE nova.openstack.common.rpc.amqp Exit code: 21 2013-10-09 09:53:48.905 27767 TRACE nova.openstack.common.rpc.amqp Stdout: '' 2013-10-09 09:53:48.905 27767 TRACE nova.openstack.common.rpc.amqp Stderr: 'iscsiadm: No session found.\n'

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-01-07 06:42:14 -0500

tsjsdbd gravatar image

on control node:

service tgt stop
service iscsitarget restart

because in /etc/cinder/cinder.conf
iscsi_helper=ietadm

edit flag offensive delete link more
1

answered 2013-11-12 23:57:03 -0500

unmesh-gurjar gravatar image

updated 2013-11-12 23:58:59 -0500

Please check if the iscsid service is running on the Cinder node, if not, start the service and retry attaching volume to instance.

edit flag offensive delete link more
0

answered 2014-10-24 14:20:45 -0500

I had similar problem, but it was caused by firewall on cinder host blocking iscsiadm port. To fix, I added the my_ip=10.0.0.41 to /etc/cinder/cinder.conf on my cinder host. Then I inserted -A INPUT -p tcp -s 10.0.0.0/24 -j ACCEPT to the iptables on cinder host.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-11-12 11:06:24 -0500

Seen: 2,305 times

Last updated: Jan 07 '14