Ask Your Question
0

Console connection on auto resumed instances

asked 2013-11-12 08:57:48 -0500

OldParrothead gravatar image

I have a compute node running some infrastructure services. As a result, when I start this node, I want the instances to just start. When I do this, they start fine, all run and I have access to them via SSH, web, MYSQL and postgres. The one thing I cannot get is console access through Horizon.

I actually get an error back when I try to access the console, an Apache Internal Server error. Before I spend all day tomorrow digging through logs, I was hoping that someone had already run into this, and had a quick fix. Tried order of boot (controller 1, compute 2, then vice versa), rebooting instances, restart nova services on controller. Nothing seems to work yet.

Thanks.

edit retag flag offensive close merge delete

Comments

Sorry, really need to see the logs :( Check the vncproxy services are running successfully.

fifieldt gravatar imagefifieldt ( 2013-11-13 19:38:47 -0500 )edit

Thanks, will be back to this Monday or Tuesday. Hopefully, I will see something and post an answer. If not, will definitely post logs.

OldParrothead gravatar imageOldParrothead ( 2013-11-15 07:00:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-11-20 09:14:28 -0500

OldParrothead gravatar image

The novnc proxy service is a stickler for timing. My findings were that after all services were ACTIVE, if I restart novnc-proxy service, they get re-picked up. If it started while they are in process, I get the above error. Kind of defeats the purpose in a large production environment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-12 08:57:48 -0500

Seen: 33 times

Last updated: Nov 20 '13