Ask Your Question
0

ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named oslo_serialization

asked 2015-07-03 06:14:47 -0500

Emad gravatar image

I keep getting this error message when I want to ./stack.sh in devstack.

I reinstalled python-setuptools, still getting this error. Also cloned oslo.serialization from openstack git https://github.com/openstack/oslo.serialization (https://github.com/openstack/oslo.ser...), but still facing the same error.

Any suggestion?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-05 14:27:24 -0500

Ahilan gravatar image

I ran into the same issue, and after investigation I confirm that oslo modules relocation is what causing the problem. I am not sure which Horizon and/or Django parts pointing to old oslo modules path, but following temporary workaround got me passed the issue. I was able to successfully install latest master (liberty) using devstack.

  1. Create "serialization" and "i18n" directories under oslo directory: for example here is the oslo path on my system - /usr/local/lib/python2.7/dist-packages/oslo/

    1. Copy following files from /usr/local/lib/python2.7/dist-packages/oslo_serialization/ directory to the new "serialization" directory under "oslo": __init__.py, __init__.pyc, jsonutils.py, jsonutils.pyc

    2. Copy following files from /usr/local/lib/python2.7/dist-packages/oslo_i18n/ directory to the new "i18n" directory under "oslo": __init__.py, __init__.pyc, _factory.py, _factory,pyc, _i18n.py, _i18n.pyc, fixture.py, fixture.pyc, log.py, log,pyc, _translate.py, _translate.pyc, _gettextutils.py, _gettextutils.pyc, _locale.py, _locate,pyc, _lazy,py, _lazy,pyc

    3. run ./stack.sh

edit flag offensive delete link more
0

answered 2015-07-06 16:29:46 -0500

sunnyarora gravatar image

Can you please check if python-pbr is installed ? Run this below command for RHEL Based distro

yum install python-pbr

Or Run below command for Ubuntu based distro

sudo apt-get install python-pbr

Then you need to start the Apache/httpd service

service httpd restart

If that doesnt workout try for direct pip install, but wont recommend

pip install pbr
edit flag offensive delete link more

Comments

Thanks for the reply. I already installed python-pbr, but still get the error.

Emad gravatar imageEmad ( 2015-07-13 03:22:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-03 06:14:47 -0500

Seen: 2,508 times

Last updated: Jul 06 '15