Ask Your Question
0

glance --unittests-only went wrong

asked 2013-05-02 02:55:23 -0500

yeluaiesec gravatar image

updated 2013-05-03 11:07:55 -0500

smaffulli gravatar image

I only want to Run unit tests only, exclude functional tests.

vi@acer$ (git::master) ./run_tests.sh -N -P --unittests-only
Usage: nosetests [options]

**nosetests: error: no such option: --exclude-dir**

for I check the run_test.sh I find that

**--unittests-only) noseopts="$noseopts --exclude-dir=glance/tests/functional"**

the exclude-dir is added by the bash scripts

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-05-02 07:13:00 -0500

unmesh-gurjar gravatar image

updated 2013-05-02 07:13:48 -0500

You need to install 'nose-exclude' package to resolve this issue (pip install nose-exclude). This package is mentioned in the 'tools/test-requires' of the Grizzly release (if you are on the latest release!).

edit flag offensive delete link more

Comments

yeah I check the 'tools/test-requires' again, it has the requirements~ but actually when the test went wrong, I went back to see the requirements,

yeluaiesec gravatar imageyeluaiesec ( 2013-05-02 07:23:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-02 02:55:23 -0500

Seen: 241 times

Last updated: May 03 '13