change the tap mtu while using linux bridges

asked 2015-07-02 19:25:10 -0500

nakul gravatar image

I have a juno system installed with seperate compute controller and neutron node. I am using linux bridges and not ovs as mechanism driver. When I create vms the tap mtu is getting set to default value 1500. How can I create vms with tap mtu other then 1500. I tried changing the nova.conf file for network_mtu=9000 but it didnt work ( I have another similar system with ovs as mechanism driver where this change is causing vms to be spawned with 9000 mtu). Is there any extra config change required for linux bridges.

edit retag flag offensive close merge delete

Comments

this was not back ported to juno https://bugs.launchpad.net/networking...

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-07-03 00:45:25 -0500 )edit

Does this mean I need to manually go and change the mtu for each vm tap I create?

nakul gravatar imagenakul ( 2015-07-06 18:19:08 -0500 )edit