Ask Your Question

How do I add correct endpoint for heat in Devstack

asked 2015-07-01 07:17:37 -0500

dnblack3 gravatar image

updated 2015-07-01 10:58:16 -0500

uts9 gravatar image

I've installed and configured Devstack as per DevStack quickstart instructions. I've also added the heat configuration to the localrc and didn't bother with Celiometer or OS Profiler. So running the

source openrc

Command, returns an empty line.

But the

heat stack-list

returns the usual error when the service is not a registered endpoint in keystone:

publicURL endpoint for orchestration service in RegionOne region not found

So, I create the service in keystone with the openstack CLI v.1.5.0 (replacing the deprecated keystone CLI)

openstack service create --os-username admin --os-password *password* --name heat --description Orchestration orchestration

I get a successful service creation

| Field       | Value                            |
| description | Orchestration                    |
| enabled     | True                             |
| id          | dded3ea6a93d4cc09144539a0dedd60d |
| name        | heat                             |
| type        | orchestration                    |

(pardon the formatting)

So now I can (with the new ID created during service registration) create an endpoint in keystone using the openstack CLI. The problem is that I don't know what format to use during endpoint creating. I've tried a variation on the following:

openstack endpoint create --os-username admin --os-password *password*--publicurl --internalurl --adminurl --region RegionOne heat

[note: I've seen the %(tenant_id)s used in these commands in Keystone, but some services have them some done. The parenthesis seem to give syntactical problems.]

This creates an endpoint successfully:

| Field        | Value                            |
| adminurl     |         |
| id           | 10ec9bbd66374b1c9bbe494de29ad357 |
| internalurl  |         |
| publicurl    |         |
| region       | RegionOne                        |
| service_id   | dded3ea6a93d4cc09144539a0dedd60d |
| service_name | heat                             |
| service_type | orchestration                    |

Now, when I give the command:

heat stack-list

I only get the following:

Unable to establish connection to

So, I'm wondering if I have the correct command/parameter format. The parenthesis seem to be an issue, but other services do not have the (tenant_id)s with them, so I don't know if this is important. Examples in the updated documentation would be useful.

Cheers derek

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-07-05 17:26:57 -0500

Steve Baker gravatar image

It sounds like you're trying to maintain a long-running devstack instance, which I believe is strongly discouraged since devstack is a development tool.

I would suggest you your devstack, follow the instructions to enable heat, then again.

edit flag offensive delete link more


Nope. Certainly NOT trying to maintain a long-running devstack instance. Just wanna play around with Orchestration (heat) to understand it a bit better. I've also done the procedure you list above after the first time failed and I get the same result. Cannot connect to the endpoint.

dnblack3 gravatar imagednblack3 ( 2015-07-07 17:23:16 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2015-07-01 07:17:37 -0500

Seen: 1,756 times

Last updated: Jul 05 '15