Ask Your Question
0

Issue with neutron agent-list

asked 2015-06-30 11:29:48 -0600

ed-dylag gravatar image

I'm setting up 3 node Kilo per installation guide for Ubuntu. Got to the part about neutron agent-list which returns nothing. Note that neutron ext-list seems to work fine.

There is an error in metadata-agent.log indicating that "neutron.agent.metadata.agent Failed reporting state!"

I have searched this error, but none of the solutions seem to apply here.

edit retag flag offensive close merge delete

Comments

Is it an HA installation?

Fsoppelsa gravatar imageFsoppelsa ( 2015-06-30 20:11:13 -0600 )edit

not HA and no, I have not installed ibaas or fwaas (following the basic 3 node configuration setup). Here is a critical error in openvswitch-agent.log. 2015-07-01 15:53:49.632 6550 CRITICAL neutron [req-1d60a592-3177-466f-95c8-cec94ff9f7eb None] No module named rabbit

ed-dylag gravatar imageed-dylag ( 2015-07-01 11:19:34 -0600 )edit

I don't think the neutron node is ever getting to the controller node as I can kill rabbitmq-server on the controller and get same error. I have tried commenting out rpc_backend = rabbit which changes the error (the neutron server then tries to find the mq on local_host, which is not what I want.

ed-dylag gravatar imageed-dylag ( 2015-07-01 11:21:56 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-30 20:08:50 -0600

nethawk gravatar image

Have you installed advanced services sunch as neutron-lbaas,neutron-fwaas? In kilo,these services are independent from neutron.

edit flag offensive delete link more
0

answered 2015-07-01 18:05:07 -0600

ed-dylag gravatar image

WOO HOO!!!! OK, I think I see what was going on. Indeed, the rabbit module can not be found. I never figured out how to install it. So I switched to rpc_backend = neutron.openstack.common.rpc.impl_kombu. BUT, this did not work right away because when you do this, the information in [oslo_messaging_rabbit] seems to be ignored.

The solution that ultimately worked for me is to move ALL of the rabbit configuration parameters to the default section. i.e. [DEFAULT] ... rpc_backend = neutron.openstack.common.rpc.impl_kombu rabbit_host = controller rabbit_userid = openstack rabbit_password = RABBIT_PASS ... (substitute your value for RABBIT_PASS)

Note that other answers involved simply commenting out rpc_backend = rabbit or changing RABBIT_PASS back to guest guest. These worked for some because the default parameters were OK for their [single node] setup. In other words, it didn't matter that [oslo_messaging_rabbit] was being ignored - the defaults worked or these folks ended up reverting some settings to default to get things working.

I hope this helps someone else...took me DAYS to figure out.

edit flag offensive delete link more

Comments

I am getting the same issue and have tried the removing rpc_backend = rabbit; as well as trying your fix in what I assume is the network nodes neutron.conf file. nothing works, still throwing the no mudule names rabbit

ivarh gravatar imageivarh ( 2015-07-23 11:38:11 -0600 )edit

stupidity on my part. forgot to install the ubuntu-cloud-keyring

ivarh gravatar imageivarh ( 2015-07-23 12:02:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-06-30 11:29:48 -0600

Seen: 421 times

Last updated: Jul 01 '15