Ask Your Question
0

How to configure the hypervisor to permit promiscuous mode on the external network

asked 2015-06-30 05:47:31 -0500

Aman gravatar image

updated 2015-06-30 05:48:50 -0500

I have a multinode kilo setup with a controller, network and 2 compute nodes.

I have configured external physical network and virtual networks, but I am not able to ping external net. The openstack kilo install guide says " If you are building your OpenStack nodes as virtual machines, you must configure the hypervisor to permit promiscuous mode on the external network". So how can I enable promiscuous mode on the hypervisor level, as " ifconfig eth0 promisc " enables it on only the host level I think.

So please provide some information on what should be the next steps.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-06-30 06:08:39 -0500

dbaxps gravatar image

I did nothing special ( what you are writing about ) on RDO Kilo on F22 Network node , However :-

[root@fedora22wks Downloads(keystone_admin)]# dmesg | grep promisc
[   14.901361] device ovs-system entered promiscuous mode
[   14.923237] device br-ex entered promiscuous mode
[   14.926733] device br-int entered promiscuous mode
[   14.928840] device br-tun entered promiscuous mode
[   21.578516] device enp2s0 entered promiscuous mode
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-30 05:47:31 -0500

Seen: 2,075 times

Last updated: Jun 30 '15