Ask Your Question
0

delete endpoint in keystone [closed]

asked 2013-11-12 00:17:20 -0500

rizka gravatar image

updated 2014-01-22 15:12:41 -0500

Evgeny gravatar image

Hi, I using I using openstack for ubuntu 12.04 in tutorial from https://cssoss.files.wordpress.com/2012/05/openstackbookv3-0_csscorp2.pdf (link text)

When I creating endpoint from keystone

awan@awan:~$ keystone endpoint-create --region myregion --service_id 260d959c4a8542f88aa2a2fdbc831157 --publicurl ’http://10.42.11.15:8776/v1/$(tenant_id)s’ --adminurl ’http://10.42.11.15:8776/v1/$(tenant_id)s’ --internalurl ’http://10.42.11.15:8776/v1/$(tenant_id)s’

then

tenant_id: command not found tenant_id: command not found tenant_id: command not found +-------------+----------------------------------+ | Property | Value | +-------------+----------------------------------+ | adminurl | ’http://10.42.11.15:8776/v1/s’ | | id | d8bf2703995f4acdba846ceadb476283 | | internalurl | ’http://10.42.11.15:8776/v1/s’ | | publicurl | ’http://10.42.11.15:8776/v1/s’ | | region | myregion | | service_id | 260d959c4a8542f88aa2a2fdbc831157 | +-------------+----------------------------------+

So, I try to delete endpoint

awan@awan:~$ keystone endpoint-delete --region myregion --service_id 260d959c4a8542f88aa2a2fdbc831157 --publicurl ’http://10.42.11.15:8776/v1/$(tenant_id)s’ --adminurl ’http://10.42.11.15:8776/v1/$(tenant_id)s’ --internalurl ’http://10.42.11.15:8776/v1/$(tenant_id)s’

but,

tenant_id: command not found tenant_id: command not found tenant_id: command not found usage: keystone [--os_username <auth-user-name>] [--os_password <auth-password>] [--os_tenant_name <auth-tenant-name>] [--os_tenant_id <tenant-id>] [--os_auth_url <auth-url>] [--os_region_name <region-name>] [--os_identity_api_version <identity-api-version>] [--token <service-token>] [--endpoint <service-endpoint>] [--username <auth-user-name>] [--password <auth-password>] [--tenant_name <tenant-name>] [--auth_url <auth-url>] [--region_name <region-name>] <subcommand> ... keystone: error: unrecognized arguments: --region --service_id 260d959c4a8542f88aa2a2fdbc831157 --publicurl ’http://10.42.11.15:8776/v1/s’ --adminurl ’http://10.42.11.15:8776/v1/s’ --internalurl ’http://10.42.11.15:8776/v1/s’</subcommand></region-name></auth-url></tenant-name></auth-password></auth-user-name></service-endpoint></service-token></identity-api-version></region-name></auth-url></tenant-id></auth-tenant-name></auth-password></auth-user-name>

What must I do to delete this ? It's okey then I not delete that endpoint ?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by rizka
close date 2014-09-17 01:46:40.902567

1 answer

Sort by » oldest newest most voted
3

answered 2013-11-12 03:19:22 -0500

dheeru gravatar image
  1. keystone endpoint-list
  2. Pick the id of the endpoint you would like to delete
  3. keystone endpoint-delete <id></id>

This will delete.

If this does not work, please paste the complete command you are running in command line. I think you are using "_" than "-"

edit flag offensive delete link more

Comments

did this solve your problem ? If yes done do let me know. We can close this issue.

dheeru gravatar imagedheeru ( 2013-11-12 05:42:19 -0500 )edit

This can happen also if you pick wrong ID from endpoint-list.

Robert gravatar imageRobert ( 2014-09-17 12:43:32 -0500 )edit

yes it works.

first type keystone endpoint-list and copy id then type keystone endpoint-delete id

PradeepNaik gravatar imagePradeepNaik ( 2014-11-13 23:17:46 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-11-12 00:17:20 -0500

Seen: 8,069 times

Last updated: Nov 12 '13