Ask Your Question
1

Nova-compute can't connect to nova-conductor

asked 2015-06-29 11:51:19 -0500

jauyeung gravatar image

I am running OpenStack on ubuntu icehouse, with one controller and one compute node. Controller is also acting as the network node.

After installing the compute node, I do not see it listed in the hypervisors list in the controller node. And i keep getting this message in nova-compute.log:

Timed out waiting for nova-conductor. Is it running? Or did this service start before nova-conductor?

I've tried restarting nova-conductor, rabbitmq and nova-compute in different orders, none has worked.

I have verified network connectivity between both nodes and the neutron-linuxbridge-agent on the compute node is registered on the controller under the neutron agent-list. Also verified that all rabbitmq credentials match across nodes. I can telnet from the compute node to the rabbitmq port on the controller.

What else can I check at this point?

edit retag flag offensive close merge delete

Comments

Enable the logs in nova.conf. then restart the nova-conductor service. debug the log of nova-conductor . If you see any error , then upload here.

Ranjit gravatar imageRanjit ( 2015-06-30 00:19:46 -0500 )edit

One possible cause is a message queue configuration error or network config that prevents the compute node from contacting the controller. EDIT: I just saw that you checked that - sorry!

Bernd Bausch gravatar imageBernd Bausch ( 2015-06-30 00:59:33 -0500 )edit

I just decided to re-install and see if that fixes anything. The weird thing is the neutron agent has no problem connecting to the controller, but nova-compute would not connect for whatever reason. Also never saw any errors in nova.conf with debugging on on both nodes. I'll report back my results

jauyeung gravatar imagejauyeung ( 2015-06-30 11:29:16 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-07-07 17:23:32 -0500

jauyeung gravatar image

After some investigation with my team, we have concluded that there potentially is an SSL issue with rabbitmq and nova (and potentially all RPC listeners). These are the versions that I am running (base OS is Ubuntu 14.04): rabbitmq-server 3.2.4-1 nova-conductor 1:2014.1.4-0ubuntu2.1 nova-compute 1:2014.1.4-0ubuntu2.1 openssl 1.0.1f-1ubuntu2.15

We had the rabbit_use_ssl flag set to true on both nodes and this has been working with the previous version of nova-compute and nova-conductor (1:2014.1.3-0ubuntu1.1). Once we did an dist-upgrade, this functionality stopped working. Disabling the flag, deleting the rabbitmq.config and restarting the 3 services, we were able to connect the compute with the controller.

edit flag offensive delete link more

Comments

Thank you, this has worked for me, i forgot to add the newton repository before editing the conf in the new compute node in my case

eriksh7 gravatar imageeriksh7 ( 2017-01-05 06:46:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-29 11:51:19 -0500

Seen: 1,050 times

Last updated: Jul 07 '15