Ask Your Question
0

Invalid URL scheme file

asked 2015-06-29 09:51:09 -0500

N.Roland gravatar image

Hi

I get this error message when i would like to use a local file in heat:

StackValidationFailed: Could not fetch remote template 'file:///home/user/templates/lb_server.yaml': Invalid URL scheme file

I add the 'file' to the allowed_schemes in urlfetch.py but is still not working.

Anyone can help me? Thanks for the help.

Regards.

edit retag flag offensive close merge delete

Comments

Are you using the standard heat stack-create command to launch the stack?

What do you get for the following?

  heat --version
Steve Baker gravatar imageSteve Baker ( 2015-07-05 17:32:24 -0500 )edit

heat --version 0.2.8, yes i used the stack-create command and i try in the horizon but not worked.

N.Roland gravatar imageN.Roland ( 2015-07-06 02:22:38 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2016-01-14 20:54:40 -0500

Jeffrey Guan gravatar image

you can also try to update your heat version to 0.2.12. And i tried on this version and didn't come across such issue.

edit flag offensive delete link more
0

answered 2015-07-06 02:21:45 -0500

N.Roland gravatar image

heat --version 0.2.8, yes i used the stack-create command and i try in the horizon but not worked.

The solution was I put these lines in to the urlfetch.py and now working.

-allowed_schemes2 = list(allowed_schemes) -allowed_schemes2.append(’file’) -allowed_schemes = tuple(allowed_schemes2)

The problem was that the 'file' word not in the list when if you write it in the allowed_schemes().

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-06-29 09:51:09 -0500

Seen: 1,280 times

Last updated: Jan 14 '16