Ask Your Question

Neutron - Can't ping to freshly created router and instances

asked 2015-06-28 15:00:57 -0500

teamhanded gravatar image

updated 2015-06-28 15:01:36 -0500

This is my topology.

I can't ping neith of the two "interfaces" on int-router ( for the inside, for the outside) and neither I can ping to from my controller node ( Floating ip's are getting correctly assigned from the pool, as far as I can tell.

[root@bablade02 images]# neutron router-show int-router

admin_state_up - True
distributed - False
external_gateway_info - {"network_id": "0f139549-399d-4032-bd32-70403203ba17", "enable_snat": true, "external_fixed_ips": [{"subnet_id": "80a8ed0c-6491-49f5-ae38-7681d6bafb9b", "ip_address": ""}]} 
ha - False
id - 19bfba0e-79f6-480b-98dc-5212e4620361
name - int-router
routes -
status - ACTIVE 
tenant_id - 28c26250737f41d69a265523ee6bb1a2

Can you help me sorting this out?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-06-29 02:20:28 -0500

SudhirH gravatar image

Have you installed the Opensatck environments in a Virtual environment? If. so have you enabled "allow promiscuous " traffic on your virtual switch/interfaces. This is a hypervisor setting.

Check the Openstack install guide

"If you choose to install on VMs, make sure your hypervisor permits promiscuous mode and disables MAC address filtering on the external network."

Regards, Sudhir

edit flag offensive delete link more


Hi Sudhir,

no, this is installed on an IBM blade. It's a two-node deployment (Keystone, Glance, Nova, Neutron, Horizon on blade01 and Cinder, Ceilometer on blade02).

teamhanded gravatar imageteamhanded ( 2015-06-29 08:28:16 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-06-28 15:00:57 -0500

Seen: 189 times

Last updated: Jun 29 '15