Ask Your Question
0

swift-init proxy start "bind_port wasn't properly set in the config file" the first few lines of proxy-server.conf: [DEFAULT]

asked 2015-06-26 13:48:25 -0500

coneheadnm gravatar image

updated 2015-06-26 14:13:30 -0500

I've tried different bind_ports and different bind_ips and the results are always the same: "bind_port wasn't properly set in the config file. It must be explicitly set to a valid port number."

Can someone help me understand the swift proxy server refuses to start using swift-init proxy start. The "bind_port ..." message is all that I can find in any of the log files. Per netstat, there are no process running on port 80 or 8080 or 8088 (some of the port numbers I have tried).

Head of /etc/swift/proxy-server.conf:

[DEFAULT]
#
#bind_ip = 0.0.0.0
bind_ip = 192.168.208.118
bind_port = 8080
# bind_timeout = 30
# backlog = 4096
# swift_dir = /etc/swift
# user = swift
edit retag flag offensive close merge delete

Comments

Make sure you have started all services of swift.

ebyenjoys gravatar imageebyenjoys ( 2015-06-28 07:49:52 -0500 )edit

After a clean reboot of the system and executing "swift-init all start", I still get the bind_port message.

coneheadnm gravatar imageconeheadnm ( 2015-06-28 11:33:12 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-07-05 02:39:39 -0500

zaitcev gravatar image

The message is caused by conf() missing the 'bind_port' key or the value not converting to int. Therefore, it's either 1) space at the end of the 8080, another invisible character, or 2) another bind_port down file.

edit flag offensive delete link more

Comments

Still get the bind port error message. Details below:

root@192:/etc/swift# swift --version python-swiftclient 2.4.0.35.g2a62dd8

grep bind_port proxy-server.conf | od -a 0000000 b i n d _ p o r t sp = sp 8 0 8 0 0000020 nl

coneheadnm gravatar imageconeheadnm ( 2015-07-05 14:25:06 -0500 )edit
0

answered 2015-07-07 11:46:12 -0500

yevp gravatar image

updated 2015-07-07 12:04:01 -0500

Please try to add in [DEFAULT] section /etc/swift/proxy-server.conf

default_port=8080

looks like issue is related to the following change: https://review.openstack.org/gitweb?p=openstack%2Fswift.git;a=commitdiff;h=b7281cf2c584cde8f516ba206d90024af03236dd

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-06-26 13:48:25 -0500

Seen: 1,465 times

Last updated: Jul 07 '15