Change metadata_urls in cloud-init

asked 2015-06-25 13:41:31 -0500

joshuamiller01 gravatar image

updated 2015-06-25 22:19:47 -0500

I host my metadata service on a specific IP, not on the default 169.254.169.254. I've changed /etc/cloud/cloud.cfg in my virtual machine image to specify a datasource url:

datasource: Ec2: metadata_urls: [ 'http://10.1.1.123:8775' ]

This eventually works - I can see that cloud-init will reach out to this and work with the metadata service, but there's a clear pause during the initial provisioning, and I can see from a packet capture that the system first tries to communicate with the 169.254.169.254:80 default end-point (thus the stall).

00:26:07.470359 IP 10.1.2.3.36269 > 169.254.169.254.80: Flags [S]

Where (else) do I need to change this to prevent the system from wasting time trying to hit the default metadata url?

edit retag flag offensive close merge delete