Ask Your Question
0

instance cannot ping outside world with domain name

asked 2015-06-25 01:36:37 -0500

JohnMar gravatar image

updated 2015-06-25 01:57:43 -0500

uts9 gravatar image

Hello all,

I am a beginner to openstack and have been struggling with this for weeks now. I have installed OpenStack Juno on Ubuntu 14.04 servers following the install guide on http://docs.openstack.org/juno/instal.... I have three nodes and I am running nova-network with one controller and two compute nodes.

Every thing is working fine and I can SSH to my instances but I can't ping the outside world with a domain name. I tried to modify dnsmasq using

dhcp-option=6,8.8.8.8

and my instance has this on resolv.conf and whenever i reset my dns server this way, i am able to ping outside two or three times and it stops resolving. I really have no idea why this is happening. Do i have to add something to iptables?

I have the following on nova-network-POSTROUTING

ACCEPT all -- 10.194.200.0/24 10.0.0.32
ACCEPT all -- 10.194.200.0/24 10.194.200.0/24 ! ctstate DNAT

where 10.194.200.0 is my flat network and 10.0.0.32 is my compute management ip

Please help and thanks for ur time.

edit retag flag offensive close merge delete

Comments

Could you please check your Security Group settings?. Usually I check iptables settings (POSTROUTING etc) in case of DNS issue.

uts9 gravatar imageuts9 ( 2015-06-25 01:42:41 -0500 )edit

Hi, I have modified my question, thanks

JohnMar gravatar imageJohnMar ( 2015-06-25 01:53:55 -0500 )edit

Please check this post.

uts9 gravatar imageuts9 ( 2015-06-25 02:08:47 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-06-26 03:34:28 -0500

RAHUL1603 gravatar image

Check whether it is a problem of name resolution or pinging. dig various site such google.co.in, facebook, etc if you get a corresponding IP then it is issue with networking. If you are able to ping 8.8.8.8 continuously and name resolution is not working (dig) then it is a problem of dnsmasq.

If dnsmasq problem then try these steps --

create a blank file and point to that file in compute nodes nova.conf (dnsmasq_config_file=/etc/dnsmasq-nova.conf) restart all the nova services, restart dnsmasq service and it should work now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-06-25 01:36:37 -0500

Seen: 503 times

Last updated: Jun 26 '15