Ask Your Question
0

Nova Compute does not send messages to syslog

asked 2015-06-24 16:16:18 -0500

Florin gravatar image

updated 2015-06-24 16:17:03 -0500

I have followed a number of tutorials online in trying to set this up but I was unsuccessful. Basically, I want all the logs in /var/log/nova/nova-compute to also be logged in another file through syslog. Here are the steps I followed:

  1. Set up the two following options in nova.conf:
use_syslog = True
syslog_log_facility = LOG_LOCAL0
  1. Restarted the openstack-nova-compute service

  2. Added the following line in rsyslog.conf:

local0.* -/var/log/nova-all.log
  1. Restarted the rsyslog service

The file nova-all never gets created, even if I try to set verbose=True and debug=True in nova.conf. I don't believe this is an issue with my rsyslog config because if I change the line: local0.* -/var/log/nova-all.log to *.* -/var/log/nova-all.log, the file will get created and logs will started generating. I think nova doesn't send it anything for some reason. I think all my nova.conf configuration is fine but I must be missing something. Any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

What version of OpenStack are you using? There was a bug in Juno that broke syslog functionality.

jxstanford gravatar imagejxstanford ( 2015-06-25 15:46:46 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-25 12:59:12 -0500

not an expert, but from experience caps matter; hence LOG_LOCAL0 != local0. unless you have LOG_LOCAL0 defined somewhere else as =local0. try syslog_log_facility = local0

edit flag offensive delete link more

Comments

This did not make a difference.

Florin gravatar imageFlorin ( 2015-06-25 13:44:13 -0500 )edit
0

answered 2015-06-25 15:59:21 -0500

First, if you are trying to use syslog with Juno, your mileage may vary. Here is a bug that severely broke syslog in Juno. It seems to be corrected in current releases of Kilo: https://bugs.launchpad.net/oslo.log/+bug/1385295 (https://bugs.launchpad.net/oslo.log/+...)

Everything else looks reasonable. You have referred to the local0 facility correctly in both locations (LOG_LOCAL0 in nova.conf and local0.* in rsyslog.conf)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-24 16:16:18 -0500

Seen: 335 times

Last updated: Jun 25 '15