Ask Your Question

Getting Error while opening horizon dashboard

asked 2015-06-24 06:31:09 -0500

sagu gravatar image

updated 2015-06-24 07:04:43 -0500

uts9 gravatar image

Hi All,

I have installed Openstack on Solaris 11.2 in virualbox. Earlier i was able to access the horizon dashboard with glance user but now i am getting error on the browser. Below is the part of error. If you need complete log i can post the same.

unsupported operand type(s) for +: 'NoneType' and 'str'Request Method: GET 
Request URL: 
Django Version: 1.4.11 
Exception Type: TypeError 
Exception Value: unsupported operand type(s) for +: 'NoneType' and 'str' 
Exception Location: /usr/lib/python2.6/vendor-packages/openstack_dashboard/wsgi/../../neutronclient/ in authenticate, line 231 
Python Executable: /usr/bin/python 
Python Version: 2.6.8 
Python Path: ['/usr/lib/python2.6/vendor-packages/openstack_dashboard/wsgi/../..',

Any idea what has gone wrong .

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-06-24 07:19:26 -0500

sagu gravatar image

updated 2015-06-25 01:51:09 -0500

If anyone looks at the answer later then here is exactly what i tried. Reset the password of users. But that didn't helped and i was getting same error. Tried in different browser (IE) earlier was mozilla, but that also didn't helped. Finally rebooted the VM and and re-opened browsers, it's working now.

PS: I hate when things work only after reboots. If anybody know a service whose restart may have also resolved this issue than please let me know.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2015-06-24 06:31:09 -0500

Seen: 111 times

Last updated: Jun 25 '15