windows networking in openstack

asked 2015-06-19 13:28:37 -0600

Fishbone gravatar image

updated 2015-07-15 17:49:36 -0600

Hello All,
I am currently running openstack under the 3-node architecture.
I have created base images for ubuntu and windows XP/7.
When an ubuntu instance is launched I have no issues connecting to the internet whatsoever. However; when I utilize any Windows instance of any architecture the internet cannot connect to sites in a web browser. I am able to ping any sites with name resolution working fine, I am also able to connect to instances on the same network just fine. When diagnosed, no results are found in windows 7, however; the windows xp instances claim that the system cannot connect to sites using HTTP/HTTPS/SSL/FTP/SFTP and I should contact the network administrator. I have never witnessed this message in XP and I am unfamiliar what could be causing this. What is causing it may also be the same root cause for all windows instances being incapable of connecting to sites.
The VIRTIO drivers seem to be installed perfectly fine and I am able to ping. When attempting to connect it will load extremely slowly until it inevitably reaches the "cannot load web page" screen.

Is there anyone that may have an idea about this, I am at a loss. I have examined ping and other packet statistics and all routing seems to work fine, could it be a latency issue? Are there any settings I need to adjust for the network cards on the images other than cloudbase-init, for linux instances as well?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2015-06-21 22:49:08 -0600

alexpilotti gravatar image

Hi, Windows XP is not supported anymore. Did you install Cloudbase-init on the Windows 7 image?

edit flag offensive delete link more


Hello, sorry for the late response, yes I have originally installed cloudbase-init. However; I noticed in the instructions of the cloud-init installation and I noticed they mention the network card configuration during setup. When I install the software that space instead mentions the serial port.

Fishbone gravatar imageFishbone ( 2015-06-22 20:01:41 -0600 )edit

Cloudbase-Init does not require a network card configuration anymore. For your scenario, you can just leave the default options, optionally selecting COM1 on the serial port dropdown in case you'd like to retrieve cloudbase-init log with nova get-console or horizon equivalent.

alexpilotti gravatar imagealexpilotti ( 2015-06-22 20:26:12 -0600 )edit

That was the only thing I noticed that was different in regards to my cloud-init installation; otherwise I am completely at a loss at what could be causing this, any ideas? By the way thanks for your help.

Fishbone gravatar imageFishbone ( 2015-06-22 22:45:42 -0600 )edit

I did some further analysis; I noticed that when observing the network adapter details the packets being sent or received does not increase. What is even stranger is that I can access certain web pages, specifically websites that are hosting exchange webmail, and a miniscule site of my own.

Fishbone gravatar imageFishbone ( 2015-06-25 12:14:10 -0600 )edit

answered 2015-07-02 11:04:44 -0600

Fishbone gravatar image

updated 2015-08-16 10:35:24 -0600

I have also discovered that this also affects linux instances. I can access websites now but I cannot do things such as download files; it seems the connection drops randomly on some requests. I have noticed while staging images that I experience the same results from vms that are NATed as opposed to bridged. Again, I will admin I am not very savvy on the way neutron works but I am sure it uses bridges. I'm sure the issue is caused by my neutron setup in some way. Is there a special step in the setup I may have missed?

Could this all be caused by the dhcp option force setting? Would that cause this?

Hello I have been doing extensive research on this and has not lead me anywhere, I have openstack setup in a 3-node architecture with all nodes being proxmox vms. I am not having trouble with any services and no errors show in any logs. My test method is creating the instance and attempting to download chrome or teamviewer, which usually fails. I can access any website with no issue and can even access my physical network. I am wondering if the issue is spawned due to a non-compliant hardware component.

edit flag offensive delete link more


If youa re using gre for tenant network than the mtu has to be < 1500 for the gre tunnel header. Because windows instance was not getting metadata, it possibly was not getting dhcp mtu either. I ahd the exact problem untill i changed mtu to 1454 inside windows guest.

capsali gravatar imagecapsali ( 2015-07-03 04:34:04 -0600 )edit

Thanks, I have attempted to change the MTU but it didn't seem to affect anything. I am not sure why but my instances are unable to download updates and other things such as google chrome or adobe flash. Any ideas?

Fishbone gravatar imageFishbone ( 2015-07-03 09:52:53 -0600 )edit

Ironically I am not having any issues with the windows XP instances. I am only having issues when making non html requests.

Fishbone gravatar imageFishbone ( 2015-07-06 17:37:49 -0600 )edit

Hello, after some troubleshooting I've realized that when I create the images I have the same issue when the put the nic in NATed mode. It does not happen in bridged mode. I admit I don't understand that much about neutron. Is there any relevance to this?

Fishbone gravatar imageFishbone ( 2015-07-11 20:42:15 -0600 )edit

answered 2016-03-30 02:30:02 -0600

Issue is not due to Openstack, its because of Windows.

You are required to change the MTU size in windows.

to check above from windows ping with MTU size of 1500 and it will fail. ping -f -l 1500 do same with mtu size of 1464 and it will be succesful. ping -f -l 1464

To change MTU you can change the DHCP setting, if using DHCP or if you are not using DHCP, change the MTU of interface manually.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-06-19 13:28:37 -0600

Seen: 1,931 times

Last updated: Mar 30 '16