Ask Your Question
1

ERROR: openstack The resource could not be found. (HTTP 404) openstack user list

asked 2015-06-17 07:34:53 -0500

rmstar gravatar image

Hi guys, I am installing Kilo and everything was going ok until my machine rebooted. Now when i tried to continue with the installation where I need to create a user with openstack user create ..... I get the following error: ERROR: openstack The resource could not be found. (HTTP 404) (Request-ID: req-4b1f3251-b5a6-44be-a179-101df26d3e19)

I then tested this with openstack user list, keystone service list,etc.... and i get the exact same error.

When i turned on debug, i see the problem is during the curl command: curl -g -i -X GET http://controller:5000/v2.0/users -H "User-Agent: python-keystoneclient" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}d8bf52c7b8068e3e1ac5e3ded0ef059b90558743" DEBUG: urllib3.connectionpool "GET /v2.0/users HTTP/1.1" 404 93 DEBUG: keystoneclient.session RESP: DEBUG: keystoneclient.session Request returned failure status: 404 ERROR: openstack The resource could not be found. (HTTP 404) (Request-ID: req-a23173b3-e675-4a2d-b562-734e84607dd6)

I "enabled" keystone by export OS_AUTH_URL=http://*:35357/v2.0 and then i was able to to keystone user-list, keystone service-list, etc....

Did I lose a configuration somewhere? Thanks for any help :)

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2018-10-09 11:19:57 -0500

Laasya gravatar image

I am seeing the same issue even after changing the version in my openrc file. Can someone help? Thanks.

edit flag offensive delete link more
0

answered 2015-06-17 21:20:41 -0500

rmstar gravatar image

Thanks Haneef. You brought me closer to finding the answer. This is what i have to add in my openrc file: export OS_IDENTITY_API_VERSION=3 Still don't understand why it was working before, but at least it is working now. :)

edit flag offensive delete link more

Comments

If you are using keystone v3, then it doesn't matter, both the ports expose all the operations. But if you are using v2 api, only few operations are exposed via 5000. Setting API_VERSION=3, defaults you to v3 api. In your original example, you are using v2 apis.

Haneef Ali gravatar imageHaneef Ali ( 2015-06-17 21:54:27 -0500 )edit

good to know. thank you, Haneef!

rmstar gravatar imagermstar ( 2015-06-18 04:30:32 -0500 )edit
0

answered 2015-06-17 14:44:20 -0500

No, you didn't. Those operations are not avialble at port 5000 and they are available only at port 35357. In your first case, you are hitting port 5000

edit flag offensive delete link more

Comments

Thanks Haneef. It is strange because this was working before. It was only after my machine crashed when this happened.

I did check my configuration and it seems that i am listening on both port 5000 and 35357. This is configured in wsgi-keystone.conf, as per kilo install guide.

rmstar gravatar imagermstar ( 2015-06-17 20:36:36 -0500 )edit
0

answered 2015-06-18 12:21:02 -0500

Jin Liu gravatar image

I met similiar 404 error in Juno use keystone v3, logs as below. I figured out in my case the openstack client version should be upgraded to 1.0.2 or later, when use 0.4.1 I got 404 error. You can check your openstack client version by 'openstack --version'. Add --debug in openstack command will print log message like 'openstack --debug user list'.

File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 194, in get_raw_token_from_identity_service _("Authorization Failed: %s") % e) AuthorizationFailure: Authorization Failed: The resource could not be found. (HTTP 404)

Hope this can help.

edit flag offensive delete link more
0

answered 2015-06-30 05:17:58 -0500

Napo Mokoetle gravatar image

I experienced the same error while trying to list hypervisors. The odd thing is this configuration all worked fine before my controller crashed! Turned out to be I was authenticating against V2.0 Keystone

root@ts036953:/home/pssuser# openstack hypervisor list
ERROR: openstack The resource could not be found. (HTTP 404) (Request-ID: req-05f42a1d-d556-43fd-9de0-64f6dfa57342)

Then I went and changed my keystone version paramater admin_auth_url within the nova.conf [neutron] section of the file on the controller node FROM

[neutron]
url = http://1y6.1z.145.1x0:9696
auth_strategy = keystone
admin_auth_url = http://196.13.145.180:35357/v2.0

TO:

[neutron] url = http://1y6.1z.145.1x0:9696
auth_strategy = keystone
admin_auth_url = http://1y6.1z.145.1x0:35357/v3

AND ALL WORKED WELL THEREAFTER. I could now list hypervisors. Hope that helps...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-06-17 07:34:53 -0500

Seen: 30,087 times

Last updated: Jun 30 '15