Ask Your Question
0

Nova compute using VMware driver instead of KVM

asked 2015-06-17 05:33:22 -0600

mkrish004c gravatar image
 Hi, 

I am facing a problem like openstack installation auto detecting the hypervisor type and 
installing the compute driver accordingly. compute driver got 
installed was vmware, but i would like to install libvirt driver. 

If i change the conf file as below and restarting nova-compute says below error
[DEFAULT] 
compute_driver=libvirt.LibvirtDriver 

[libvirt] 
virt_type = qemu 

i am getting error like 

2015-06-16 15:08:02.887 21269 INFO nova.virt.driver [-] Loading compute driver 'libvirt.LibvirtDriver'
2015-06-16 15:08:02.892 21269 INFO nova.openstack.common.periodic_task [-] Skipping periodic task _periodic_update_dns because its interval is negative
2015-06-16 15:08:02.903 21269 ERROR nova.virt.driver [-] Unable to load the virtualization driver
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver Traceback (most recent call last):
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver   File "/usr/lib/python2.7/dist-packages/nova/virt/driver.py", line 1389, in load_compute_driver
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver     virtapi)
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver   File "/usr/lib/python2.7/dist-packages/oslo_utils/importutils.py", line 52, in import_object_ns
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver     return import_class(import_str)(*args, **kwargs)
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver   File "/usr/lib/python2.7/dist-packages/oslo_utils/importutils.py", line 27, in import_class
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver     __import__(mod_str)
2015-06-16 15:08:02.903 21269 TRACE nova.virt.driver ImportError: No module named libvirt
edit retag flag offensive close merge delete

Comments

What say virsh --connect qemu:///system ?

dbaxps gravatar imagedbaxps ( 2015-06-17 09:28:32 -0600 )edit

to run paralell kvm/vmware i installed a 2nd controllernode (novaconductor) and compude node especially for vmware

Thomas Li gravatar imageThomas Li ( 2015-06-17 10:42:40 -0600 )edit

Thanks for reply, Now i have manually installed KVM and the dependent packages in my compute set up and configuring it. I am not sure why does it take VMware driver automatically.

mkrish004c gravatar imagemkrish004c ( 2015-06-17 11:26:39 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2015-06-25 05:29:00 -0600

mkrish004c gravatar image
o   I installed the following packages manually and followed some commands after installation.
   apt-get install qemu-kvm ebtables iproute pm-utils libxml2-utils 
   After these package installation faced an issue while installing libparted0debian1, so need to update source list for this installation with the below package
•   deb http://archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse 
•   deb http://archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse 
•   deb http://archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse 
•   deb http://archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse 
•   deb http://archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
   sudo apt-get update && sudo apt-get install libparted0debian1
   apt-get install libvirt-bin virt-manager
   chown root:libvirtd /dev/kvm
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-17 05:33:22 -0600

Seen: 813 times

Last updated: Jun 25 '15