migration error ----"Warning: Permanently added '10.0.0.10' (ECDSA) to the list of known hosts."

asked 2015-06-16 07:25:15 -0500

abhishek-talwar gravatar image

updated 2015-06-16 07:26:31 -0500

I have a multinode OpenStack kilo setup with 1 controller, 1 network and 2 compute nodes. When I am trying to migrate a VM from 1 compute host to the other, it results in an error.

Stderr: u"Warning: Permanently added '10.0.0.10' (ECDSA) to the list of known hosts.\r\n"

I have followed these steps:

  1. make sure your nova user has appropriate shell set, if not run: usermod -s /bin/bash nova
  2. Now generate SSH keys using "nova" users. su - nova ssh-keygen -t rsa Save the key without a passphrase.
  3. Next up we need to configure SSH to not do host key verification, unless you want to manually SSH to all compute nodes that exist and accept the key

cat << EOF > ~/.ssh/config Host * StrictHostKeyChecking no UserKnownHostsFile=/dev/null EOF

  1. Next we need to make sure we copy the the contents of id_rsa.pub to authorized_keys and set the mode on it correctly cat ~/.ssh/id_rsa.pub > .ssh/authorized_keys chmod 600 .ssh/authorized_keys

Now comes the important part, you will need to tar up and copy the ~nova/.ssh directory to every single compute node you have provisioned. This way all compute nodes will be able to SSH to the remote host to run the commands required to copy an instance over, and resize it. But the error still persists.

Moreover, I have copied the .ssh directory from the controller to both the compute nodes. I have configured passwordless authentication between controller and compute nodes. But when I am trying for a passwordless authentication from the nova user, it is giving permission denied error. And if I enter the nova password it gives that the password is incorrect while it is the same password that is mentioned in the /etc/nova/nova.conf file.

So what should I do ?

edit retag flag offensive close merge delete