openstack Invalid volume client version '2'

asked 2015-06-11 15:49:01 -0500

TheMan gravatar image

I just started using the unified openstack client, and thought everything was working fine - I can run most commands, but some, like when I try to do a 'server create', and a couple of other commands, it gives me this same error:

ERROR: openstack Invalid volume client version '2'. must be one of: 1

I've checked most of my logs, no smoking gun there. Any ideas? What's a 'volume client' anyway?

Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-08-26 21:52:51 -0500

annegentle gravatar image

updated 2015-08-26 22:04:04 -0500

I'm getting the same error after installing a stable/kilo version of devstack and the 1.0.4 openstack client.

Considering that Volume v2 API support just landed in the client this month, https://review.openstack.org/#/q/topi... I am guessing we need a newer openstack client release. So, I used pip install python-openstackclient --upgrade and got 1.0.6 and this error went away.

To answer your second question, there's a second API and endpoint for block storage, or volumes that can be attached the instance at launch.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-11 15:49:01 -0500

Seen: 607 times

Last updated: Aug 26 '15