Ask Your Question
0

Error: could not install dependencies - tempest

asked 2015-06-11 14:53:54 -0500

Ufuntu gravatar image

Hello,

Can anyone advise if they have encountered the below error when running devstack. The devstack deployment I am trying to implement is a multi-node stack with

1 control node vm, 1 compute node vm and opendaylight running on the host

vm's are running on Ubuntu server 14.04 LTS in virtualbox

I start Opendaylight in the host before trying to stack the controller node but receive the below error

summary ____________________________________ 2015-06-11 18:37:14.820 | ERROR: venv: could not install deps [-r/opt/stack/tempest/requirements.txt, -r/opt/stack/tempest/test-requirements.txt]; v = InvocationError('/opt/stack/tempest/.tox/venv/bin/pip install -U -r/opt/stack/tempest/requirements.txt -r/opt/stack/tempest/test-requirements.txt (see /opt/stack/tempest/.tox/venv/log/venv-1.log)', 2)

Have tried, "upgrading setuptools within the virtualenv" (sudo pip install -U virtualenv), as a workaround according to bug fix - https://bugs.launchpad.net/tempest/+bug/1405579 (https://bugs.launchpad.net/tempest/+b...) - but I am still receiving the same error

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-01 13:34:17 -0500

chirag-shahani gravatar image

updated 2015-07-01 13:35:12 -0500

In your tempest directory, do pip install -r requirements.txt and run stack.sh again. \m/

edit flag offensive delete link more

Comments

I tried the above solution but it didnot work. I am having the same problem.

pm gravatar imagepm ( 2018-10-25 03:31:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-06-11 14:53:54 -0500

Seen: 2,798 times

Last updated: Jul 01 '15