Ask Your Question
0

Horizon Interface Timeout

asked 2015-06-11 10:53:03 -0600

bradnold gravatar image

updated 2015-06-11 13:33:42 -0600

When logging into the horizon interface I frequently get random problems where horizon seems to be unable to access certain services.

Example: When accessing images section of horizon it frequently says "Error: Unable to retrieve image list."

Additionally, I've been having issues being able to upload images. My guests seem to frequently "disappear and reappear" from the network topology section. Lastly, sometimes I need to try multiple times to actually get logged in.

Any idea's what could cause this or what logs I should check to figure out what is going on?

When logging into the horizon interface I frequently get random problems where horizon seems to be unable to access certain services.

Example: When accessing images section of horizon it frequently says "Error: Unable to retrieve image list."

Additionally, I've been having issues being able to upload images, and my guests seem to frequently "disappear and reappear" from the network topology section.

Any idea's what could cause this or what logs I should check to figure out what is going on?

edit retag flag offensive close merge delete

Comments

Run the required service in verbose/debug mode and then see the logs.

For your case , enable the log in glance service and run it.

  1. Verify that your request from horizon is received at glance or not.
  2. See the error and then try to solve.
Ranjit gravatar imageRanjit ( 2015-06-12 01:28:54 -0600 )edit

/etc/glance/glance-registry.conf /etc/glance/glance-api.conf are both set to verbose = True The timeout initially was not occurring until I started playing with one of my instances in a console session strangely. Here's the glance http://pastebin.com/m0qA4U6T I don't know what to gather form them.

bradnold gravatar imagebradnold ( 2015-06-12 08:23:02 -0600 )edit

Is this concerning? MariaDB [(none)]> show status like 'Conn%'; +---------------+-------+ | Variable_name | Value | +---------------+-------+ | Connections | 17400 | +---------------+-------+

bradnold gravatar imagebradnold ( 2015-06-12 08:30:41 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-06-12 08:38:58 -0600

bradnold gravatar image

Looks like openstack is eating all my connections

MariaDB [(none)]> show processlist;
+-------+----------+-------------------------------------------------+----------+---------+------+-------+------------------+----------+
151 rows in set (0.00 sec)

MariaDB [(none)]> select @@global.max_connections;
+--------------------------+
| @@global.max_connections |
+--------------------------+
|                      151 |
+--------------------------+
1 row in set (0.00 sec)

MariaDB [(none)]> show status like '%onn%';
+--------------------------+-------+
| Variable_name            | Value |
+--------------------------+-------+
| Aborted_connects         | 429   |
| Connections              | 17459 |
| Max_used_connections     | 152   |
| Ssl_client_connects      | 0     |
| Ssl_connect_renegotiates | 0     |
| Ssl_finished_connects    | 0     |
| Threads_connected        | 151   |
+--------------------------+-------+
7 rows in set (0.00 sec)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-11 10:53:03 -0600

Seen: 496 times

Last updated: Jun 12 '15