Ask Your Question
0

where to get libvirt 1.2.9 for CentOS 7 [closed]

asked 2015-06-09 03:28:54 -0500

DaveJ gravatar image

Hi, I've been trying to use the NUMA pinning features available in Kilo running on CentOS 7.1, but unfortunately I get the following error:

libvirtError: unsupported configuration: Per-node memory binding is not supported with this QEMU

I can't find supported packages for libvirt 1.2.9 on CentOS. Does anyone have an offical repo or build?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by DaveJ
close date 2015-06-10 02:21:58.607191

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-06-09 10:25:06 -0500

dbaxps gravatar image

updated 2015-06-09 11:08:18 -0500

Looks stuff you need is here :-
https://repos.fedorapeople.org/repos/...
Yes

[root@ip-192-169-142-37 ~]# uname -a
Linux ip-192-169-142-37.ip.secureserver.net 3.10.0-229.4.2.el7.x86_64 #1 SMP Wed May 13 10:06:09 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[root@ip-192-169-142-37 ~]# virsh --connect qemu:///system
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # version
Compiled against library: libvirt 1.2.11
Using library: libvirt 1.2.11
Using API: QEMU 1.2.11
Running hypervisor: QEMU 2.2.0

You may build yourself ( unofficilal )

Download from https://libvirt.org/sources/
libvirt-1.2.9-1.fc19.src.rpm

yum install yum-utils
yum-builddep libvirt
rpm -iv libvirt-1.2.9-1.fc19.src.rpm
cd /root/rpmbuild/SPECS
rpmbuild -bb libvirt.spec

Up on competition

cd ../RPMS/x86_62
yum install libvirt-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-client-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-config-network-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-config-nwfilter-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-interface-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-lxc-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-network-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-nodedev-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-nwfilter-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-qemu-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-secret-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-driver-storage-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-kvm-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-daemon-lxc-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-debuginfo-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-devel-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-docs-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-lock-sanlock-1.2.9-1.el7.centos.x86_64.rpm \
libvirt-login-shell-1.2.9-1.el7.centos.x86_64.rpm



virsh # version
Compiled against library: libvirt 1.2.9
Using library: libvirt 1.2.9
Using API: QEMU 1.2.9
Running hypervisor: QEMU 1.5.3
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-09 03:28:54 -0500

Seen: 2,796 times

Last updated: Jun 09 '15