DHCP request from controller not arriving to VM on the compute node.

asked 2015-06-04 16:16:25 -0500

antonov gravatar image

Hello,

Here is my issue, I have a kilo openstack architecture with two nodes, the first one contain keystone, glance, nova (controller) nova (compute) neutron (controller network and compute), the dashboard and cinder. On the other node, I have only nova (compute) and neutron (compute) . I have two network in neutron (ext and test (internal)) When I try to create a VM on the first node in any network, everything is fine, when I try on the second one, with only one interface in the test network, the VM is not receving any IP, I have the cloud-init-nonet[13.11]: error and I can't ping any other VM or router on the network. Here are what I could find from ovs-vsctl (i think the problem may come from there)

ovs-vsctl show on the controller node :

4517033c-182c-4535-afe7-af382edda9c3
Bridge br-tun
    fail_mode: secure
    Port br-tun
        Interface br-tun
            type: internal
    Port "gre-0a000102"
        Interface "gre-0a000102"
            type: gre
            options: {df_default="true", in_key=flow, local_ip="10.0.1.1", out_key=flow, remote_ip="10.0.1.2"}
    Port patch-int
        Interface patch-int
            type: patch
            options: {peer=patch-tun}
Bridge br-int
    fail_mode: secure
    Port "tap0d72d0ab-c0"
        tag: 2
        Interface "tap0d72d0ab-c0"
            type: internal
    Port "tap279d8789-49"
        tag: 1
        Interface "tap279d8789-49"
            type: internal
    Port "qr-ea612608-cf"
        tag: 1
        Interface "qr-ea612608-cf"
            type: internal
    Port "qg-678dcc4a-c5"
        tag: 2
        Interface "qg-678dcc4a-c5"
            type: internal
    Port int-br-ex
        Interface int-br-ex
            type: patch
            options: {peer=phy-br-ex}
    Port br-int
        Interface br-int
            type: internal
    Port patch-tun
        Interface patch-tun
            type: patch
            options: {peer=patch-int}
Bridge br-ex
    Port "em4.10"
        Interface "em4.10"
    Port phy-br-ex
        Interface phy-br-ex
            type: patch
            options: {peer=int-br-ex}
    Port br-ex
        Interface br-ex
            type: internal
ovs_version: "2.3.1"

ovs-vsctl show on the compute node :

8d0913f2-05dc-4e46-b47c-060b5bf54616
Bridge br-int
    fail_mode: secure
    Port patch-tun
        Interface patch-tun
            type: patch
            options: {peer=patch-int}
    Port br-int
        Interface br-int
            type: internal
Bridge br-tun
    fail_mode: secure
    Port patch-int
        Interface patch-int
            type: patch
            options: {peer=patch-tun}
    Port br-tun
        Interface br-tun
            type: internal
ovs_version: "2.3.1"

ovs-ofctl show br-tun on the controller

OFPT_FEATURES_REPLY (xid=0x2): dpid:00007e45eb3aee49
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 3(patch-int): addr:ee:65:2d:06:05:84
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 4(gre-0a000102): addr:1e:24:f3:13:05:4b
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br-tun): addr:7e:45:eb:3a:ee:49
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0

ovs-ofctl show br-tun from the compute node

OFPT_FEATURES_REPLY (xid=0x2): dpid:00000acc0c3ba940
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 3(patch-int): addr:22:8b:58:e8:1d:60
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br-tun): addr:0a:cc:0c:3b:a9:40
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0

I have ... (more)

edit retag flag offensive close merge delete