deleted instance running on compute

asked 2015-06-04 11:19:47 -0600

Uzi gravatar image

updated 2015-06-04 11:21:40 -0600

Hi All

i am using openstack Juno controller/compute 2014.2.2 on ubuntu 14.04

recently i have deleted 2 instances using the Dashboard successfully, however the instances still running active on the compute

when searching the nova-compute.log i have seen that the process stop from logging few minutes before the deletion took place and also service nova-compute status was running

further on as i understand there is a periodic task '_cleanup_running_deleted_instances' that should find such instances and by default (reap) will delete those instances and that it is configure to run every 1800 sec by default.

however the instances remain as active in the compute

in the controller the nova-compute service were UP

further on after restart the instances were not deleted and instead they change to shutoff

from watching the log i noticed that it detected the discrepancy but again they been only shutdown and not deleted (udefine)

my question : what is needed to be configured in order to make sure deleted instances are confirmed as deleted during run-time and start of nova-compute ?

bellow log od the nova-compute.log only from the reboot time ,not before

2015-06-04 17:51:08.488 2625 DEBUG nova.openstack.common.service [-] running_deleted_instance_action = reap log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/cfg.py:1992
2015-06-04 17:51:08.488 2625 DEBUG nova.openstack.common.service [-] running_deleted_instance_poll_interval = 1800 log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/cfg.py:1992
2015-06-04 17:51:08.489 2625 DEBUG nova.openstack.common.service [-] running_deleted_instance_timeout = 0 log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/cfg.py:1992
2


2015-06-04 17:51:08.966 2625 DEBUG nova.openstack.common.service [-] ******************************************************************************** log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/cfg.py:2002
2015-06-04 17:51:08.970 2625 AUDIT nova.service [-] Starting compute node (version 2014.2.1)
2015-06-04 17:51:08.973 2625 DEBUG nova.virt.libvirt.driver [-] Connecting to libvirt: qemu:///system _get_new_connection /usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py:724
2015-06-04 17:51:10.974 2625 DEBUG nova.virt.libvirt.driver [-] Registering for lifecycle events <nova.virt.libvirt.driver.LibvirtDriver object at 0x7f091253a8d0> _get_new_connection /usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py:741
2015-06-04 17:51:10.976 2625 DEBUG nova.virt.libvirt.driver [-] Registering for connection events: <nova.virt.libvirt.driver.LibvirtDriver object at 0x7f091253a8d0> _get_new_connection /usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py:752
2015-06-04 17:51:10.990 2625 DEBUG nova.virt.libvirt.config [-] Generated XML ('<cpu>\n  <arch>x86_64</arch>\n  <model>Haswell</model>\n  <vendor>Intel</vendor>\n  <topology sockets="1" cores="4" threads="2"/>\n  <feature name="abm"/>\n  <feature name="acpi"/>\n  <feature name="ds"/>\n  <feature name="ds_cpl"/>\n  <feature name="dtes64"/>\n  <feature name="est"/>\n  <feature name="f16c"/>\n  <feature name="ht"/>\n  <feature name="monitor"/>\n  <feature name="osxsave"/>\n  <feature name="pbe"/>\n  <feature name="pdcm"/>\n  <feature name="pdpe1gb"/>\n  <feature name="rdrand"/>\n  <feature name="smx"/>\n  <feature name="ss"/>\n  <feature name ...
(more)
edit retag flag offensive close merge delete

Comments

Please check that compute service is running on compute node. Also confirm on below entry in nova.conf on compute node refer here

running_deleted_instance_action = reap
sunnyarora gravatar imagesunnyarora ( 2015-06-06 09:16:36 -0600 )edit

the log shows that its using this attribute value

2015-06-04 17:51:08.488 2625 DEBUG nova.openstack.common.service [-] running_deleted_instance_action = reap
Uzi gravatar imageUzi ( 2015-06-07 05:52:07 -0600 )edit