Ask Your Question
0

How to avoid FAIL with user credentials when starting Autoscaling Template

asked 2013-11-08 07:50:03 -0500

bnoe gravatar image

I'm running a single node devstack installation with stable/havanna - ceilometer and heat included When i start AutoScalingCeilometer template (from master rel. of heat-templates), i need to start the stack as admin user, as starting the stack from demo fails with

h-api-log results in: 2013-11-07 09:55:33.439 DEBUG root [-] JSON response : {"stacks": [{"description": "Creates an autoscaling wordpress application using Ceilometer.", .. "stack_status_reason": "Resource create failed: Forbidden: You are not authorized to perform the requested action, admin_required.

looking at heat-engine the h-eng.log gives

2013-11-07 10:03:53.703 9795 DEBUG keystoneclient.httpclient [-] Request returned failure status: 403 request /opt/stack/python-keystoneclient/keystoneclient/httpclient.py:123

Obviously a user needs to created what is permitted for admin only - Does that makes sense? But, even when starting the stack with admin (in project/tenant) demo heat event-list stackname reports ElasticLoadBalancer | 314 | Error: Resource create failed: WaitConditionTimeout: 0 of 1 received | CREATE_FAILED

What could i check? What am i missing to make it work?

Thanks in advance

PS: the VM is started and i can login and ping to outside world

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-04 06:48:23 -0500

Kunal Patil gravatar image

updated 2013-12-04 07:00:11 -0500

I am not sure of the user privilege problem, as we create stacks from horizon. We log in using the tenant specific user, and face no issues with permissions.

If you can login to the VM created, please check the log at /var/log/heat-provision.log. This should give you an idea as to what happened. Usually, there is some error with one of the bash commands provided. Increasing the Timeout can also help. For example:

ElasticLoadBalancer: Type: AWS::ElasticLoadBalancing::LoadBalancer Properties: AvailabilityZones: {'Fn::GetAZs': ''} Listeners: - {LoadBalancerPort: '80', InstancePort: '80', Protocol: HTTP} HealthCheck: {Target: 'HTTP:80/', HealthyThreshold: '3', UnhealthyThreshold: '5', Interval: '30', Timeout: '5'}

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-08 07:50:03 -0500

Seen: 618 times

Last updated: Dec 04 '13