Ask Your Question
0

Cinder tempest volume tests failed

asked 2015-06-04 00:40:49 -0500

spradeepv gravatar image

I deployed a single node devstack(Liberty) on Ubuntu 14.04. When i run tempest volume tests, some tests failed. Following are the steps which I followed to run the tempest tests

  • git clone https://github.com/openstack-dev/devstack.git (https://github.com/openstack-dev/devs...) (https://github.com/openstack-dev/devs...)
  • cd devstack
  • Edit local.conf as shown below:
[[local|localrc]]
ADMIN_PASSWORD=password
DATABASE_PASSWORD=password
RABBIT_PASSWORD=password
SERVICE_PASSWORD=password
SERVICE_TOKEN=password
HOST_IP=192.168.4.113
DEST=/opt/stack
enable_service mysql
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-l3
enable_service q-dhcp
enable_service q-meta
enable_service neutron
enable_service tempest

# These options define  expected driver capabilities
CINDER_ENABLED_BACKENDS=hp_3par:3parfc
TEMPEST_VOLUME_DRIVER=hp_3par_fc
TEMPEST_VOLUME_VENDOR="Hewlett-Packard"
TEMPEST_STORAGE_PROTOCOL=FC

VERBOSE=True
DEBUG=True
LOGFILE=/opt/stack/screen-logs/stack.sh.log
USE_SCREEN=True
LOGDAYS=1
SCREEN_LOGDIR=/opt/stack/screen-logs
RECLONE=True

[[post-config|/etc/cinder/cinder.conf]]
[DEFAULT]
zoning_mode=fabric
default_volume_type=3parfc
enabled_backends=3parfc

[fc-zone-manager]
fc_fabric_names=F1
fc_san_lookup_service=cinder.zonemanager.drivers.brocade.brcd_fc_san_lookup_service.BrcdFCSanLookupService
zone_driver=cinder.zonemanager.drivers.brocade.brcd_fc_zone_driver.BrcdFCZoneDriver
zoning_policy=initiator-target

[F1]
fc_fabric_address=10.24.49.116
fc_fabric_user=zoneAdmin
fc_fabric_password=password
fc_fabric_port=22

[3parfc]
hp3par_api_url=https://10.24.49.111:8080/api/v1
hp3par_username=3paradm
hp3par_password=passw0rd
hp3par_debug=False
san_ip=10.24.49.111
san_login=3paradm
san_password=passw0rd
volume_backend_name=3parfc
hp3par_cpg=FC_r5
volume_driver=cinder.volume.drivers.san.hp.hp_3par_fc.HP3PARFCDriver

Following error is thrown for most of the failed test cases:

ERROR: setUpClass (tempest.api.volume.admin.test_snapshots_actions.SnapshotsActionsV2Test)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "tempest/test.py", line 272, in setUpClass
    six.reraise(etype, value, trace)
  File "tempest/test.py", line 265, in setUpClass
    cls.resource_setup()
  File "tempest/api/volume/admin/test_snapshots_actions.py", line 40, in resource_setup
    'available')
  File "tempest/services/volume/json/volumes_client.py", line 173, in wait_for_volume_status
    raise exceptions.VolumeBuildErrorException(volume_id=volume_id)
tempest.exceptions.VolumeBuildErrorException: Volume 5ce55c63-286d-4542-9f82-ecbfa4913629 failed to build and is in ERROR status

Am I missing something?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-24 09:33:35 -0500

cinderela gravatar image

Hi spradeepv,

I am running the tempest volume tests as well but on a RedHat Openstack Platform. I think that in order to build a Class , you need to add the following to tempest.conf: [volume] build_interval = 1 build_timeout = 196 vendor_name = Infinidat storage_protocol = iSCSI

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-04 00:40:49 -0500

Seen: 388 times

Last updated: Apr 24 '17