Ask Your Question
1

Packets cannot be forwarded through LinuxBridge

asked 2015-06-03 00:27:09 -0500

anonymous user

Anonymous

Hi all,

I deployed OpenStack Juno (3nodes deployment aka a Controller, a Compute, and a Network Node) with Vlan setting using LinuxBridge instead of OVS. There are several issues but the most serious problem is that a VM cannot be assigned IP address via qdhcp on Network Node.

I kept track of why the problem happened. First, I set up the vm to transmit dhcp request packets using udhcpc command, and did tcpdump at each port/bridge. The connection sequence between a vm and a qdhcp is [Compute Node] vm nic -> linuxbridge tap -> linuxbridge -> ethx.x (VLAN) -> ethx (Physical nic) -> [Network Node] ethx (Physical nic) -> ethx.x -> linuxbridge -> linuxbridge tap -> qdhcp nic

I could detect the dhcp request packet until Network Node's physical nic, i.e., ethx. After the ethx.x, however, I could not tcpdump any packets. On the other hand, if the qdhcp sent a packet like 'ip netns exec qdhcp ping x.x.x.x' the packet arrived at Compute Node's physical nic.

As a result, I assume that packets are dropped at receiver side's linuxbridge. I downed all the services related iptables, firewalld, ebtables, etc., so I think there is no rules or something like that to drop packets.

Could anybody experience this kind of problem and solve it?

Thank you in advance!

edit retag flag offensive close merge delete

Comments

could be https://bugs.launchpad.net/neutron/+b.... On the network node, you will need to continue tcpdumping in the qdhcp namespace

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-06-03 01:20:58 -0500 )edit

Thank you! I wrote several detail information. Any advice and comments would be really appreciated!

kim0412 gravatar imagekim0412 ( 2015-06-03 02:44:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-06-03 02:43:15 -0500

kim0412 gravatar image

updated 2015-06-03 02:53:20 -0500

Thank you very much for your reply. I did tcpdumping (tcpdump -nei ethx) on both Compute Node's physical nic and Network Node's physical nic, and the results are different as below:

  1. On the Compute Node 00:38:20.108076 fa:16:3e:01:4f:7c > Broadcast, ethertype 802.1Q (0x8100), length 326: vlan 1, p 0, ethertype IPv4, 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from fa:16:3e:01:4f:7c, length 280

  2. On the Network Node 00:38:20.108332 ff:ff:ff:ff:fa:16 > Broadcast, ethertype Unknown (0x3e01), length 322: 0x0000: 4f7c 0800 4500 0134 0000 0000 4011 79ba O|..E..4....@.y. 0x0010: 0000 0000 ffff ffff 0044 0043 0120 e7a8 .........D.C.... 0x0020: 0101 0600 cb28 0878 0000 0000 0000 0000 .....(.x........ 0x0030: 0000 0000 0000 0000 0000 0000 fa16 3e01 ..............>. 0x0040: 4f7c 0000 0000 0000 0000 0000 0000 0000 O|.............. 0x0050: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x0060: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x0070: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x0080: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x0090: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x00a0: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x00b0: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x00c0: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x00d0: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x00e0: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x00f0: 0000 0000 0000 0000 0000 0000 0000 0000 ................ 0x0100: 0000 0000 0000 0000 0000 0000 6382 5363 ............c.Sc 0x0110: 3501 013d 0701 fa16 3e01 4f7c 3902 0240 5..=....>.O|9..@ 0x0120: 3707 0103 060c 0f1c 2a3c 0c75 6468 6370 7.......*<.udhcp 0x0130: 2031 2e32

The tcpdump result seems quite weird on Network Node. I could not get any tcpdump result from ethx.x to brqxxxx-xx on Network node; nothing was detected while sending dhcp request from a vm.

By the way, I think I need to describe information what I've been setting for the testbed;

I used VMware Workstation and set 3 nodes for the deployment. The host OS is centos7 with the latest kernel version (3.10.0-229.4.2.el7.x86_64), and the guest OS is cirros-0.3.3-x86_64. Qemu is used as hypervisor.

And I configured the dhcp-option-force option from 26,1454 as guide to 26,1400 in /etc/neutron/dnsmasq-neutron.conf file. The other configurations for neutron networking with linuxbridge are probably fine imo. If you need I'll attached it.

edit flag offensive delete link more

Comments

try setting the NICs in VMware GUI to promiscous mode

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-06-03 12:04:43 -0500 )edit

I'm not sure what you mean, but I already set the physical nic on each host, i.e., Network Node and Compute Node, to Promisc Mode, I'm wonder whether the setting is working correctly or not since I'm using NetworkManager; does it provide functions for setting Promisc mode via nmcli command?

kim0412 gravatar imagekim0412 ( 2015-06-03 19:15:08 -0500 )edit

ok, i stopped and disabled NetworkManager and start network for Promisc mode. But it still doesn't work... I noticed that the vm even could not connect to metadata while booting with Unreachable status.

kim0412 gravatar imagekim0412 ( 2015-06-03 20:28:47 -0500 )edit

ethertype 0x3e01 ??? what kind of vnics are you using in vmware? virtio, e1000 ...

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-06-04 11:53:06 -0500 )edit

VMware Workstation does not provide the function that selects vnic types, so that I don't know what kind of vnic type is used for the VMware. I set network connection type to Host-only. I think I need to change the testbed environment from VMware to VirtualBox. :(

kim0412 gravatar imagekim0412 ( 2015-06-07 19:27:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-03 00:27:09 -0500

Seen: 398 times

Last updated: Jun 03 '15