Ask Your Question
3

heat-keystone-setup-domain command doesnt works on my Openstack kilo setup

asked 2015-06-03 00:07:11 -0600

Radhakrishnan Rk gravatar image

updated 2015-06-03 00:15:46 -0600

uts9 gravatar image

Hii all,

I recently configured all in one openstack kilo setup.I added heat service to it.I followed the documentation given by openstack http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_heat.html ,I can't execute ''heat-keystone-setup-domain'' command.It is not available in /bin directory.

Finally I added the particular command form git repository..git clone link https://github.com/openstack/heat
https://github.com/openstack/heat/tree/master/bin

root@kilo:~#git clone https://github.com/openstack/heat.git

root@kilo:~#cp /root/heat/bin/heat-keystone-setup-domain /etc/bin

I can able to perform that command after doing this.

Why these commands are added to my /bin folder by default??

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-02 23:37:13 -0600

Gauvain Pocentek gravatar image

There was a bug in the heat package in ubuntu, it's fixed now. Upgrade the heat-common package and you will get the script.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-03 00:07:11 -0600

Seen: 697 times

Last updated: Jul 02 '15