Neutron: br-tun not working on compute node [closed]

asked 2015-06-02 11:29:50 -0500

anonymous user

Anonymous

updated 2015-06-02 14:36:06 -0500

I have a basic setup of one controller node, one network node and one compute node, all on different physical machines. Spinning up machines works, but they don't get any IP, I've tracked it down to Neutron issues on the compute node. OpenStack has created a br-int interface and a br-tun interface and from the little I understand traffic should be going from br-int to br-tun and then to network node.

Using tcpdump and snooper interfaces I figured out I had traffic on br-int and the patch-interface on br-int, but not the patch-interface on br-tun or br-tun. So obviously this patch interface thing isn't working. I got rid of them and created a veth pair which I used instead. Now I have veth0 on br-int and veth1 on br-tun, and traffic from the VM is visible on br-int, veth0 and veth1, but still not on br-tun!

I've been trying to get OpenStack working for 3 months having this issue of Neutron not working on the compute node. So any help at all is much appreciated. Output of ovs-vsctl show:

[root@devstack-compute01 neutron]# ovs-vsctl show
40ab6bdc-ec3e-4599-b520-7a0fb6f2e3f7
    Bridge br-tun
        Port "vxlan-c0a86d61"
            Interface "vxlan-c0a86d61"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.109.99", out_key=flow, remote_ip="192.168.109.97"}
        Port "veth1"
            Interface "veth1"
        Port br-tun
            Interface br-tun
                type: internal
    Bridge br-int
        fail_mode: secure
        Port "qvoaaf249c0-f2"
            tag: 1
            Interface "qvoaaf249c0-f2"
        Port "qvof8d4d7ed-27"
            tag: 2
            Interface "qvof8d4d7ed-27"
        Port "veth0"
            Interface "veth0"
        Port "qvo23fec136-e9"
            tag: 3
            Interface "qvo23fec136-e9"
        Port "qvo04a4d4da-46"
            tag: 1
            Interface "qvo04a4d4da-46"
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "2.3.0"

/etc/neutron/plugins/ml2/ml2_conf.ini on controller node

[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges = 65537:69999
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
tenant_network_type = vxlan
enable_tunneling = True
tunnel_type = vxlan
tunnel_id_ranges = 65537:69999
[agent]
tunnel_types = vxlan

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini on network node:

[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges = 65537:69999
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
tenant_network_type = vxlan
enable_tunneling = True
tunnel_type = vxlan
tunnel_id_ranges = 65537:69999
local_ip = 192.168.109.97
[agent]
tunnel_types = vxlan

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini on Compute node:

[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges = 65537:69999
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
tenant_network_type = vxlan
enable_tunneling = True
tunnel_type = vxlan
tunnel_id_ranges = 65537:69999
local_ip = 192.168.109.99
[agent]
tunnel_types = vxlan
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by dbaxps
close date 2015-06-02 13:00:54.808884

Comments

Please , post /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini on Network Node and Compute Nodes
and /etc/neutron/plugins/ml2/ml2_conf.ini on Controller Node ( as UPDATE to your question)

dbaxps gravatar imagedbaxps ( 2015-06-02 12:38:01 -0500 )edit