Ask Your Question
0

neutron qrouter-<ID> is not created in network namespace

asked 2015-06-02 02:15:40 -0500

anonymous user

Anonymous

updated 2015-06-11 07:49:05 -0500

image description hello stackers,

i created a virtual router and connected the router interface to two networks.

router is created and i can see it in neutron router-list but when i type ip netns list i cannot see a qrouter-<ID>

Can somebody help me?

edit retag flag offensive close merge delete

Comments

I have the same issue. I have an admin tenant where everything (thus far) works perfectly. I have another tenant where the router namespace doesn't exist. The 3 interfaces on that router (one to the external network, two to internal networks) are down. That network DOES have the qdhcp namespace.

hat gravatar imagehat ( 2015-07-30 17:16:01 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2015-10-03 17:46:14 -0500

Zatarra gravatar image

updated 2015-10-03 17:52:31 -0500

I have the same problem, it might be related to the fact that I am running aio.. and when I did the install NetworkManager was active, even now is disabled.

I found the problem, the solution was to check the logs and notice the warning message that was spamming for hours.. I had two external networks :(. I have deleted the wrong one and the qrouters appeared instantaneously.

edit flag offensive delete link more

Comments

thanks for the answer, i also had the same issue. But does that mean we cant create 2 external networks on the openstack? If i have multiple interfaces i guess i should be able to create multiple external networks connected to different interfaces?

mostwanted gravatar imagemostwanted ( 2016-09-15 04:15:02 -0500 )edit
2

answered 2015-06-02 08:07:22 -0500

Vinoth gravatar image

This is not the valid solution but still...!

Try to list the router after launching any one VM & attach the floating IP to it.

edit flag offensive delete link more

Comments

Thank you for reply. neutron router-list is working fine, floating IPs assigned, VM also ACTIVE & RUNNING. only issue is ip netns show it must display a qrouter-*******. if a virtual router exists. that is not happening why?

PradeepNaik gravatar imagePradeepNaik ( 2015-06-05 00:58:17 -0500 )edit
1

answered 2015-06-02 08:28:01 -0500

dbaxps gravatar image

updated 2015-06-02 08:36:18 -0500

Private network is attached to Neutron router as follows
Create an internal network and its associated subnet

  $ source keystonerc_demo
  $ neutron net-create int
  Created a new network:
  +----------------+--------------------------------------+
  | Field          | Value                                |
  +----------------+--------------------------------------+
  | admin_state_up | True                                 |
  | id             | 1a4157a6-5cf2-46e3-bdea-1533c8f54cdf |
  | name           | int                                  |
  | shared         | False                                |
  | status         | ACTIVE                               |
  | subnets        |                                      |
  | tenant_id      | 2c845a6ad20e45ccb0b045cee27a9661     |
  +----------------+--------------------------------------+

  $ neutron subnet-create int 30.0.0.0/24 --dns_nameservers list=true
  192.168.122.1
  Created a new subnet:
  +------------------+--------------------------------------------+
  | Field            | Value                                      |
  +------------------+--------------------------------------------+
  | allocation_pools | {"start": "30.0.0.2", "end": "30.0.0.254"} |
  | cidr             | 30.0.0.0/24                                |
  | dns_nameservers  | 192.168.122.1                              |
  | enable_dhcp      | True                                       |
  | gateway_ip       | 30.0.0.1                                   |
  | host_routes      |                                            |
  | id               | 04b95f13-cc77-4f9a-8206-7f6ed183461d       |
  | ip_version       | 4                                          |
  | name             |                                            |
  | network_id       | 1a4157a6-5cf2-46e3-bdea-1533c8f54cdf       |
  | tenant_id        | 2c845a6ad20e45ccb0b045cee27a9661           |
  +------------------+--------------------------------------------+

Connect the above subnet to the router by setting it as a port

  $ neutron router-interface-add router1 \
  04b95f13-cc77-4f9a-8206-7f6ed183461d
  Added interface 63ea2815-b524-4a12-931d-3e7db60ea170 to router router1.

Public external network "ext" is attached to Neutron router as follows

Connect the router to ext by setting the gateway for the router as ext

  $ neutron router-gateway-set router1 ext
  Set gateway for router router1

Then launch VM && assign public IP and check ip netns as @vinoth suggested.
You can do the same via dashboard as demo ( for instance)

1. Assign interface for tenant's network at neutron router
2. Setting gateway to external network at the same router
edit flag offensive delete link more

Comments

It is according installation guide. two tenant networks created both have few vms. And i even created the router, status is also active and attached these two tenant networks to it.The interface attached to the router status is down. Also in ip netns a qrouter-**must be there which is also missi

PradeepNaik gravatar imagePradeepNaik ( 2015-06-05 00:41:18 -0500 )edit

i done this setup earlier but this error i didnt faced. My pointer to issue is with L3-agent but logs are not helpful over here.

PradeepNaik gravatar imagePradeepNaik ( 2015-06-05 00:43:03 -0500 )edit

hello dpaxps what you said is the routine procedure available in installation guide. plz check the image where status remained DOWN soon after creating it.

PradeepNaik gravatar imagePradeepNaik ( 2015-06-12 00:15:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-06-02 02:15:40 -0500

Seen: 4,206 times

Last updated: Oct 03 '15