Ask Your Question
0

swift-proxy service not start on opensuse 13.2

asked 2015-06-01 08:45:52 -0500

Mohib gravatar image

updated 2015-06-01 08:47:05 -0500

Hi all, Recently i installed openstack kilo on opensuse 13.2 but openstack-swift-proxy service not start . proxy service startup log pest in below --------

Error trying to load config from /etc/swift/proxy-server.conf: PyECLib>=1.0.7 Error trying to load config from /etc/swift/proxy-server.conf: PyECLib>=1.0.7

please help me for solve this problem.

Thanks

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-05 02:49:17 -0500

toabctl gravatar image

PyECLib and all the required libraries are available in the build service. See https://build.opensuse.org/project/show/Cloud:OpenStack:Master (https://build.opensuse.org/project/sh...) . All the packages are build for the openSUSE 13.2 distribution (and some others). So you can just use theses packages instead of creating your own.

edit flag offensive delete link more
0

answered 2015-06-01 18:33:41 -0500

zaitcev gravatar image

There's not much you can do but obtain the PyECLib, liberasurecode, gf-complete, and jerasure packages by any means necessary.

Fedora has test RPMs in review phase if you want to use those: https://bugzilla.redhat.com/show_bug.... - PyECLib https://bugzilla.redhat.com/show_bug.... - liberasurecode https://bugzilla.redhat.com/show_bug.... - jerasure https://bugzilla.redhat.com/show_bug.... - gf-complete

At this point if may be easier to create a sacrificial VM and pollute the heck of it with pip.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-01 08:45:52 -0500

Seen: 228 times

Last updated: Jun 01 '15