Ask Your Question
0

Failed to launch instance: No valid host was found ..DHCP error

asked 2015-06-01 02:27:27 -0500

fhussain gravatar image

updated 2015-06-01 08:27:43 -0500

Hi,

When I try to launch an instance, I get this error:

Unable to launch the instance. Please try again later. No valid host was found.

I have opened the screen for openstack by : screen -x stack

I can see error in neutron dhcp agent (q-dhcp) screen.

ERROR neutron.agent.dhcp_agent [-] Unable to enable dhcp for 9e116c5f-04ba-437c-82c0-3feca0706ebd.
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent Traceback (most recent call last):
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/dhcp_agent.py", line 129, in call_driver
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     getattr(driver, action)(**action_kwargs)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/dhcp.py", line 175, in enable
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     reuse_existing=True)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/dhcp.py", line 883, in setup
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     namespace=network.namespace)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/interface.py", line 196, in plug
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     namespace_obj.add_device_to_namespace(ns_dev)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/ip_lib.py", line 157, in add_device_to_namespace
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     device.link.set_netns(self.namespace)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/ip_lib.py", line 243, in set_netns
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     self._as_root('set', self.name, 'netns', namespace)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/ip_lib.py", line 218, in _as_root
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     kwargs.get('use_root_namespace', False))
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/ip_lib.py", line 71, in _as_root
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     namespace)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/ip_lib.py", line 82, in _execute
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     root_helper=root_helper)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent   File "/opt/stack/neutron/neutron/agent/linux/utils.py", line 76, in execute
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent     raise RuntimeError(m)
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent RuntimeError:
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent Command: ['sudo', '/usr/local/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ip', 'link', 'set', 'tapd9dab467-5b', 'netns', 'qdhcp-9e116c5f-04ba-437c-82c0-3feca0706ebd']
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent Exit code: 2
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent Stdout: ''
2015-06-01 18:21:21.325 TRACE neutron.agent.dhcp_agent Stderr: 'RTNETLINK answers: Invalid argument\n'

Please help me figure out the solution.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-01 09:31:49 -0500

nd gravatar image

Usually - the error No valid host was found comes from nova-scheduler if after applying all scheduler filters there is no hypervisor capable of satisfying the request and this is before any networking is configured for the instance - so not sure if the above two are for the same instance? can you double check?

what is the flavor of instance you are trying to launch - vcpus, memory and disk? and what does your hepervisor report as available capacity when you login as admin?

Also - just have a look at following link, which although is very very old see if that helps - https://bugzilla.redhat.com/show_bug....

edit flag offensive delete link more

Comments

I am trying to launch m1.nano flavor. When I login as admin, the hypervisor shows this capacity. VCPUs: used 1 0f 2, Memory Usage: used 576MB of 7.3GB, Disk Usage: used 0 bytes of 25GB.

fhussain gravatar imagefhussain ( 2015-06-02 00:05:42 -0500 )edit
0

answered 2015-06-01 07:57:31 -0500

pawankkamboj gravatar image

check neutron-dhcp-agent service is running also see log.

edit flag offensive delete link more

Comments

neutron-dhcp-agent service is running. I have edited the question to add the logs.

fhussain gravatar imagefhussain ( 2015-06-01 08:26:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-06-01 02:27:27 -0500

Seen: 753 times

Last updated: Jun 01 '15