Ask Your Question
0

cinder-api and bind_host parameter

asked 2015-05-28 20:29:46 -0600

Guillaume gravatar image

updated 2015-05-28 20:30:23 -0600

Hi,

My 3 controllers run all OpenStack APIs and HAProxy service. I must tell to cinder-api to run on a specific IP address to avoid conflict with HAProxy (port 8776) but i can't find how. For Glance, i used the bind_host variable to do that but it doesn't works with Cinder.

I looked in this documentation but i found nothing.

Thanks for your help.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-05-29 12:53:07 -0600

jdexter gravatar image

Cinder API and Cinder Scheduler can run in A/A, but if you have cinder-volume using the same backend you will need to run them in Active/Passive. (https://bugzilla.redhat.com/show_bug....)

When setting up Cinder, set the cinder endpoint to the VIP, and then in cinder.conf set #my_ip= to the local bind address.

edit flag offensive delete link more
0

answered 2015-05-29 13:49:54 -0600

Guillaume gravatar image

Thanks for pointing me to the cinder-volume A/A problem.

For cinder-api, even if i set my_ip to 192.168.100.205, the bind occurs on *:8776 and not on 192.168.100.205:8776. To work around the problem, i set the cinder endpoint and the VIP to port 8777.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-28 20:29:46 -0600

Seen: 299 times

Last updated: May 29 '15