Ask Your Question
0

packstack external network behind NAT

asked 2015-05-27 22:06:45 -0500

WilliamCaban gravatar image

I have a configuration where the Openstack external network is behind a firewall, like this:

(internet)--->NAT--->(Openstack External)-->(router1)...

Is there a way to specify the public IP for horizon so the correct entries are generated for Nova NOVNCPROXY and Horizon for the Apache config?

Right now my hack to get Horizon working is to do something like this:

Disable default html site

sudo mv
/etc/httpd/conf.d/15-default.conf
/etc/httpd/conf.d/15-default.conf-disabled

Enable Openstack Horizon as the default

sudo sed -i '/ServerAlias\ localhost/a ServerAlias default' /etc/httpd/conf.d/15-horizon_vhost.conf

Restart Apache for changes to take effect

sudo service httpd restart

And to get the Nova web console working (novncproxy) I do something like this:

myip=<my_public_ip>
sudo sed -i -e "s,^novncproxy_base_url=.*$,novncproxy_base_url=http://$myip:6080/vnc_auto.html," /etc/nova/nova.conf

Is there a way to accomplish this with packstack?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-05-28 12:28:42 -0500

jdexter gravatar image

No there is not a way to automatically do this workaround in packstack. Packstack will set horizon to use the IP of the controller node.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-27 22:06:45 -0500

Seen: 515 times

Last updated: May 28 '15