Special character in devstack config file

asked 2015-05-27 20:57:16 -0600

xiangfeiz gravatar image

updated 2015-05-27 20:59:00 -0600

I don't know how the special characters should be escaped when putting into devstack's config files.

For an example, if I have '$' in my password, how should I put it in localrc? I have tested the following which do not work.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2015-05-28 01:55:42 -0600

Maybe password='c$b' would work too, that should get the shell parsing out of the loop.

edit flag offensive delete link more

answered 2015-05-28 00:12:28 -0600

uts9 gravatar image

DevStack configuration parameters are parsed by shell scripts whereas Oslo libraries are used for reading OpenStack configuration files. So you need to escape special characters.

edit flag offensive delete link more

answered 2015-05-27 20:58:41 -0600

xiangfeiz gravatar image

I was testing another solution while asking the question. The one works is


I don't know if quotes are necessary.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-05-27 20:57:16 -0600

Seen: 388 times

Last updated: May 28 '15