Ask Your Question
1

ValueError: DVR deployments for VXLAN/GRE underlays require L2-pop to be enabled, in both the Agent and Server side

asked 2015-05-27 14:32:20 -0600

paullaurence gravatar image

updated 2015-05-27 15:03:26 -0600

rbowen gravatar image

Hi, I have DVR running perfectly on Juno (1 controller, 1 network, 2 compute) I am working through a kilo install but after configuring Neutron on the network node I noticed that Open vSwitch agent was not present when running 'neutron agent-list' on the controller.

After going back to the network node I see the 'openvswitch-agent.log' outputing:

ValueError: DVR deployments for VXLAN/GRE underlays require L2-pop to be enabled, in both the Agent and Server side.

my ml2_conf.ini is similar to below:

[ml2]
type_drivers = flat,gre
tenant_network_types = gre
mechanism_drivers = openvswitch,l2population

[ml2_type_flat]
flat_networks = external

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]
local_ip = TENANT_NETWORK_TUNNELS_INTERFACE_IP_ADDRESS
enable_tunneling = True
bridge_mappings = external:br-ex

[agent]
l2population = True
tunnel_types = gre
enable_distributed_routing = True
arp_responder = True

Anyone else had this issue?

edit retag flag offensive close merge delete

Comments

try l2_population = True

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-05-28 11:50:32 -0600 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-05-28 15:22:08 -0600

paullaurence gravatar image

Hi, Yes the answer was l2_population = True rather than l2population = True I realized I had made the mistake earlier today. Everything working fine now! :-)

Thanks for the replies!

edit flag offensive delete link more

Comments

I'm glad this is working and I'm stuck on Liberty but with a different issue, so your configs help

Kernel_Panic gravatar imageKernel_Panic ( 2016-02-10 17:58:04 -0600 )edit
0

answered 2015-05-28 01:38:27 -0600

dbaxps gravatar image

You wrote :- I noticed that Open vSwitch agent was not present when running 'neutron agent-list' on the controller On Controller Node

[root@ip-192-169-142-127 ~(keystone_admin)]# neutron agent-list
+--------------------------------------+--------------------+----------------------------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host                                   | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+----------------------------------------+-------+----------------+---------------------------+
| 08c29b8b-5990-4429-966d-96a6acf07307 | Open vSwitch agent | ip-192-169-142-137.ip.secureserver.net | :-)   | True           | neutron-openvswitch-agent |
| 382feb49-bf74-4145-9994-b40bb0b325e2 | DHCP agent         | ip-192-169-142-147.ip.secureserver.net | :-)   | True           | neutron-dhcp-agent        |
| 699bfa45-3204-4f41-b807-6559f99f73ab | L3 agent           | ip-192-169-142-147.ip.secureserver.net | :-)   | True           | neutron-l3-agent          |
| 7b3663dd-0941-4899-b62c-959d6661fd21 | Metadata agent     | ip-192-169-142-147.ip.secureserver.net | :-)   | True           | neutron-metadata-agent    |
| f2c1ed0e-09d4-4bc8-ae74-5c5020b0c5eb | Open vSwitch agent | ip-192-169-142-147.ip.secureserver.net | :-)   | True           | neutron-openvswitch-agent |
+--------------------------------------+--------------------+----------------------------------------+-------+----------------+---------------------------+

On Controller Node

[root@ip-192-169-142-127 neutron(keystone_admin)]# cat plugin.ini | grep -v ^$| grep -v ^#
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch,l2population
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

On Network && Compute Node

[root@ip-192-169-142-147 openvswitch(keystone_admin)]# cat ovs_neutron_plugin.ini | grep -v ^#|grep -v ^$
[ovs]
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip =192.168.122.147
bridge_mappings =physnet1:br-ex
enable_tunneling=True
[agent]
polling_interval = 2
tunnel_types =vxlan
vxlan_udp_port =4789
l2_population = True
arp_responder = True 
enable_distributed_routing = False
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[root@ip-192-169-142-137 openvswitch]# cat ovs_neutron_plugin.ini | grep -v ^$| grep -v ^#
[ovs]
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip =192.168.122.137
bridge_mappings =physnet1:br-ex
enable_tunneling=True
[agent]
polling_interval = 2
tunnel_types =vxlan
vxlan_udp_port =4789
l2_population = True
arp_responder = True
enable_distributed_routing = False
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
edit flag offensive delete link more
-1

answered 2015-05-28 07:14:55 -0600

GPlat gravatar image

Hi,

I have the same error installing from scratch a Kilo release. l2population is enabled both controller and network/compute nodes.

Cheers, Giuseppe

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-27 14:32:20 -0600

Seen: 636 times

Last updated: May 28 '15