Ask Your Question
0

Network node cannot ping a site on Internet

asked 2015-05-27 10:38:34 -0500

tonysosos gravatar image

I set the network interfaces of my network node follow the doc on http://openstack.org eth0 used for external network, the IP address is allocated by the lab's admin, it is fixed. When I change the /etc/network/interfaces to

auto eth0
iface eth0 inet manual
    up ip link set dev $IFACE up
    down ip link set dev $IFACE down

and reboot I cannot ping the http://openstack.org WHY? Because this configuration is used for DHCP situation? What should I do to make it can connect the Internet?

edit retag flag offensive close merge delete

Comments

I think the configuration of default gateway is correct. The IP is fixed. If I change the /etc/network/interfaces to

auto eth0

iface eth0 inet static

address 202.112.113.213

netmask 255.255.255.0

network 202.112.113.0

gateway 202.112.113.1

then it can ping the site. why?

tonysosos gravatar imagetonysosos ( 2015-05-28 20:43:39 -0500 )edit

sorry about the format..

tonysosos gravatar imagetonysosos ( 2015-05-28 20:46:03 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-05-28 12:42:34 -0500

jdexter gravatar image

updated 2015-05-29 13:02:02 -0500

Check your default gateway if you cannot ping outside of your broadcast domain.

Without a gateway, the network packets do not know where to go if a system on the current network does not know the destination address. http://www.printertechs.com/other-ins...

edit flag offensive delete link more
0

answered 2015-05-30 03:04:57 -0500

nd gravatar image

updated 2015-05-30 03:08:44 -0500

On the network node there also needs to be an external bridge - usually configured with the name br-ex. Have you added this external bridge using command ovs-vsctl add-br br-ex ?

The connectivity on the network node is as follows: An external bridge is to be created (br-ex) using above mentioned command. This external bridge should be used to bridge your integration bridge (br-int) and external interface (in your case eth0 as I understand). Thus you need to add the eth0 interface to your br-ex bridge using command ovs-vsctl add-port br-ex eth0

Once this is done, you need to update your /etc/network/interfaces file with the following two set of entries - for eth0 and for br-ex [I guess you must be missing the br-ex entry - where you have assign the IP address in the range of your external network and gateway to this br-ex. Also you should configure your eth0 interface in promiscuous mode]

auto eth0

iface eth0 inet manual

up ifconfig \$IFACE 0.0.0.0 up

up ip link set \$IFACE promisc on

down ip link set \$IFACE promisc off

down ifconfig \$IFACE down

auto br-ex

iface br-ex inet static

address 202.112.113.213

netmask 255.255.255.0

gateway 202.112.113.1

dns_nameservers your_dns_servers

Exclude the extra line feeds in the post - I had to add, other wise it was appearing as a single line. Once you do this, just reboot your server once so any existing IP set on eth0 or any configurations you might have tried will not have effect and the configurations will be set afresh.

If this does not work for you, please share the output of ifconfig -a ovs-vsctl show cat /etc/network/interfaces

HTH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-27 10:35:58 -0500

Seen: 264 times

Last updated: May 30 '15