Ask Your Question
0

Murano installation issue

asked 2015-05-26 19:41:50 -0500

vahidh gravatar image

updated 2015-05-27 18:57:15 -0500

I have followed the development version of Murano installation instruction at http://murano.readthedocs.org/en/late..., but am running into an issue.

After the installation, I created an Environment and loaded one of the out of the box packages (WordPress). When I go to Murano > Application Catalog > Applications, I see WordPress listed there, with two buttons: "Add to Env" and "Quick Deploy". However, clicking on any of these buttons causes an error (as if the target page does not exist). For example, when I click on "Add to Env" I get this error:

TemplateDoesNotExist at /murano/catalog/add/057e8979229546c79381a45be144ff88/eb0f68a4988e42e8b9275e3485b49c24

services/wizard_create.html

Request Method: GET

Request URL: http://x.x.x.x/murano/catalog/add/057...

Django Version: 1.7.8

Exception Type: TemplateDoesNotExist

Exception Value: services/wizard_create.html

Exception Location: /usr/local/lib/python2.7/dist-packages/django/template/loader.py in find_template, line 136

Python Executable: /usr/bin/python

Python Version: 2.7.6

Python Path:
['/opt/stack/horizon/openstack_dashboard/wsgi/../..', '/opt/stack/keystone', '/opt/stack/glance', '/opt/stack/cinder', '/opt/stack/neutron', '/opt/stack/nova', '/opt/stack/horizon', '/opt/stack/heat', '/opt/stack/python-muranoclient', '/opt/stack/murano', '/opt/stack/murano-dashboard', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/opt/stack/horizon/openstack_dashboard']

Full error is attached.murano_error.jpg

Did I miss some installation steps on top of what is in that page? Thank you.

--Vahid

UPDATE

In the attached screenshot's Template-loader postmortem I see that the file wizard_create.html is not found in a number of folders including /opt/stack/murano-dashboard/muranodashboard/templates/services/. When I look at that folder there is a file named _wizard_create.html.

edit retag flag offensive close merge delete

Comments

Hi vahidh i'm trying to install murano using the same guide that you had used on a ubuntu 14.04, but when i access the dashboard i can't find the Murano Panel ! so i guess that i missed some configuration steps.! can you tell me what are the other config steps that i could had missed and thanks

Badis BA gravatar imageBadis BA ( 2016-05-08 10:08:33 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-05-28 12:49:58 -0500

vahidh gravatar image

updated 2015-06-17 11:40:32 -0500

The error seems to be related to https://bugs.launchpad.net/murano/+bu.... Waiting for the bug fix to verify.

UPDATE: With the bug fix I was able to stack without an error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-26 19:41:50 -0500

Seen: 345 times

Last updated: Jun 17 '15