l3-agent, dvr doesn't tag packets for floating ips

asked 2015-05-22 14:17:09 -0500

tom_c gravatar image

In short, floating ips don't work when distributed virtual routing is enabled in my setup. The interfaces, iptables rules, etc. are correct. Packet captures shows mangled packets with the correct ip destination address and correct src and destination mac addresses. I've noted in ovs that a vlan tag is supplied; manually configuring the vlan tag permits communication.

The setup is using Juno 2014.2.3. The l3_agent.ini configuration on the compute node is:

[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
external_network_bridge = xenbr3
enable_metadata_proxy = False
agent_mode = dvr
ovs_integration_bridge=xapi1

and the ml2_conf.ini is

[ml2]
type_drivers = gre
tenant_network_type = gre
mechanism_driver = openvswitch,l2population
[ml2_type_gre]
tunnel_id_ranges=1:1000
[ovs]
local_ip=10.255.255.22
integration_bridge=xapi1
enable_tunneling=True
[agent]
tunnel_types=gre
root_helper = /usr/bin/neutron-rootwrap-xen-dom0 /etc/neutron/rootwrap.conf
l2_population = True
enable_distributed_routing = True
arp_responder=True
[securitygroup]
enable_security_group = False

I've verified the namespace, interfaces, and iptables are corrected and correct.

[root@hv-1c-03 ~]# ip netns list
fip-923a95ab-1869-4b8b-8232-b8e1c745e101
qrouter-e6d98ee6-46a0-4f17-a16f-e21d82851838

[root@hv-1c-03 ~]# ip netns exec fip-923a95ab-1869-4b8b-8232-b8e1c745e101 ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: fpr-e6d98ee6-4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 62:53:9c:0f:df:11 brd ff:ff:ff:ff:ff:ff
29: fg-b8c102cd-2e: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT
    link/ether fa:16:3e:4b:f2:38 brd ff:ff:ff:ff:ff:ff
[root@hv-1c-03 ~]# ip netns exec fip-923a95ab-1869-4b8b-8232-b8e1c745e101 ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: fpr-e6d98ee6-4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 62:53:9c:0f:df:11 brd ff:ff:ff:ff:ff:ff
    inet 169.254.31.29/31 scope global fpr-e6d98ee6-4
       valid_lft forever preferred_lft forever
    inet6 fe80::6053:9cff:fe0f:df11/64 scope link
       valid_lft forever preferred_lft forever
29: fg-b8c102cd-2e: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:4b:f2:38 brd ff:ff:ff:ff:ff:ff
    inet 172.29.3.172/14 brd 172.31.255.255 scope global fg-b8c102cd-2e
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe4b:f238/64 scope link
       valid_lft forever preferred_lft forever
[root@hv-1c-03 ~]# ip netns exec qrouter-e6d98ee6-46a0-4f17-a16f-e21d82851838 ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: rfp-e6d98ee6-4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether d6:86:51:51:69:55 brd ff:ff:ff:ff:ff:ff
28: qr-45a298dd-ed: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT ...
(more)
edit retag flag offensive close merge delete