Ask Your Question
0

Starting nova-compute fails with 'Missing CPU model name' error

asked 2015-05-22 08:05:36 -0500

Manuel gravatar image

Hi all

I installed the latest dev stack on a ubuntu-trusty-14.04 on an AWS instance. I know this issue is somehow related to how the host systems CPU is determined and I followed all the advice I found so far in the internet.

Here the relevant part of the /etc/nova/nova.conf:

[libvirt]
inject_partition = -2
live_migration_uri = qemu+ssh://stack@%s/system
use_usb_tablet = False
cpu_mode = none
virt_type = qemu

Stacktrace when startign nova-compute:

libvirtError: XML error: Missing CPU model name
2015-05-22 12:48:42.589 ERROR nova.openstack.common.threadgroup [req-0878165d-c99a-470c-86cd-8784217c3e49 None None] XML error: Missing CPU model name
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup Traceback (most recent call last):
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/openstack/common/threadgroup.py", line 145, in wait
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     x.wait()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/openstack/common/threadgroup.py", line 47, in wait
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     return self.thread.wait()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 175, in wait
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     return self._exit_event.wait()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/usr/local/lib/python2.7/dist-packages/eventlet/event.py", line 121, in wait
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     return hubs.get_hub().switch()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/usr/local/lib/python2.7/dist-packages/eventlet/hubs/hub.py", line 294, in switch
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     return self.greenlet.switch()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 214, in main
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     result = function(*args, **kwargs)
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/openstack/common/service.py", line 502, in run_service
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     service.start()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/service.py", line 158, in start
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     self.manager.init_host()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/compute/manager.py", line 1270, in init_host
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     self.driver.init_host(host=self.host)
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/virt/libvirt/driver.py", line 522, in init_host
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup     self._do_quality_warnings()
2015-05-22 12:48:42.589 TRACE nova.openstack.common.threadgroup   File "/opt/stack/nova/nova/virt/libvirt/driver.py ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-03-01 16:42:13 -0500

mriedem gravatar image
edit flag offensive delete link more
0

answered 2015-05-26 19:45:01 -0500

jdexter gravatar image

Based on the notes form nova.conf

Change your settings to

# Set to "host-model" to clone the host CPU feature flags; to
# "host-passthrough" to use the host CPU model exactly; to
# "custom" to use a named CPU model; to "none" to not set any
# CPU model. If virt_type="kvm|qemu", it will default to
# "host-model", otherwise it will default to "none" (string
# value)

cpu_mode=<None>
or
cpu_mode=host-model
edit flag offensive delete link more

Comments

I'm also facing the same error and tried the same as mentioned above but it didn't worked for me.did it worked for you?

ashu gravatar imageashu ( 2015-07-21 05:40:46 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-22 08:05:36 -0500

Seen: 688 times

Last updated: Mar 01 '16